<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://spokanefavs.com/xmlrpc.php" />
<meta property="og:title" content="ICR on the Road &#8230; and on the Ropes - SpokaneFāVS"/>
<meta property="og:type" content="article"/>
<meta property="og:description" content="ICR on the Road ... and on the Ropes Commentary By Jim Downard The Institute for Creation Research ("/>
<meta property="og:url" content="https://spokanefavs.com/icr-on-the-road-and-on-the-ropes/"/>
<meta property="og:site_name" content="SpokaneFāVS"/>
<meta property="og:image" content="https://spokanefavs.com/wp-content/uploads/2022/10/Creationism-vs.-Evolution.png" />
								<script async defer data-pin-hover="true" data-pin-tall="true" data-pin-lang="en" src="//assets.pinterest.com/js/pinit.js"></script>
																	<script async src= "https://www.googletagmanager.com/gtag/js?id=85992401"></script>
									<style type= "text/css">div.heateor_sssp_horizontal_sharing a{width:6.6923076923077%!important}div.heateor_sssp_horizontal_sharing span.heateor_sssp_svg{width:calc(100% - 1px)!important;}div.heateorSsspTCBackground{width:100%!important}			.heateor_sssp_button_instagram span.heateor_sssp_svg,a.heateor_sssp_instagram span.heateor_sssp_svg{background:radial-gradient(circle at 30% 107%,#fdf497 0,#fdf497 5%,#fd5949 45%,#d6249f 60%,#285aeb 90%)}
											.heateor_sssp_horizontal_sharing span.heateor_sssp_svg,.heateor_sssp_standard_follow_icons_container .heateor_sssp_svg{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
				.heateor_sssp_horizontal_sharing .heateorSsspTCBackground{
			color:#666;
		}
						div.heateor_sssp_horizontal_sharing .heateor_sssp_square_count{display: block}
						.heateor_sssp_horizontal_sharing span.heateor_sssp_svg:hover,.heateor_sssp_standard_follow_icons_container .heateor_sssp_svg:hover{
						border-color: transparent;
		}
		.heateor_sssp_vertical_sharing span.heateor_sssp_svg,.heateor_sssp_floating_follow_icons_container .heateor_sssp_svg{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
				.heateor_sssp_vertical_sharing .heateorSsspTCBackground{
			color:#666;
		}
						.heateor_sssp_vertical_sharing span.heateor_sssp_svg:hover,.heateor_sssp_floating_follow_icons_container .heateor_sssp_svg:hover{
						border-color: transparent;
		}
						div.heateor_sssp_vertical_sharing .heateor_sssp_square_count{display: block}
				@media screen and (max-width:783px) {.heateor_sssp_vertical_sharing{display:none!important}}@media screen and (max-width:783px) {.heateor_sssp_floating_follow_icons_container{display:none!important}}</style><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<script>                function apbct_attach_event_handler__backend(elem, event, callback) {                    if(typeof window.addEventListener === "function") elem.addEventListener(event, callback);                    else                                                elem.attachEvent(event, callback);                }                apbct_attach_event_handler__backend(window, 'DOMContentLoaded', function(){                    if (typeof apbctLocalStorage === "object") {                        apbctLocalStorage.set('ct_checkjs', '1323108990', true );                    } else {                        console.log('APBCT ERROR: apbctLocalStorage object is not loaded.');                    }                  });    </script>
	<!-- This site is optimized with the Yoast SEO Premium plugin v19.3 (Yoast SEO v19.8) - https://yoast.com/wordpress/plugins/seo/ -->
	<title>ICR on the Road ... and on the Ropes - SpokaneFāVS</title>
	<meta name="description" content="Creationism has two main songs: “Origins or Bust” about life itself or aspects of it being impossible other than via divine creation, and “Gee Whiz” stuff marveling at the amazing (fill in the blank) but not going too far into whatever science literature there may be on them, especially their evolutionary history." />
	<link rel="canonical" href="https://spokanefavs.com/icr-on-the-road-and-on-the-ropes/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="ICR on the Road ... and on the Ropes" />
	<meta property="og:description" content="Creationism has two main songs: “Origins or Bust” about life itself or aspects of it being impossible other than via divine creation, and “Gee Whiz” stuff marveling at the amazing (fill in the blank) but not going too far into whatever science literature there may be on them, especially their evolutionary history." />
	<meta property="og:url" content="https://spokanefavs.com/icr-on-the-road-and-on-the-ropes/" />
	<meta property="og:site_name" content="SpokaneFāVS" />
	<meta property="article:publisher" content="http://www.facebook.com/SpokaneFAVS" />
	<meta property="article:published_time" content="2022-10-16T15:27:35+00:00" />
	<meta property="article:modified_time" content="2022-10-16T15:27:37+00:00" />
	<meta property="og:image" content="https://spokanefavs.com/wp-content/uploads/2022/10/Creationism-vs.-Evolution.png" />
	<meta property="og:image:width" content="650" />
	<meta property="og:image:height" content="350" />
	<meta property="og:image:type" content="image/png" />
	<meta name="author" content="Jim Downard" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@spokanefavs" />
	<meta name="twitter:site" content="@spokanefavs" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Jim Downard" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="5 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">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</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="SpokaneFāVS &raquo; Feed" href="https://spokanefavs.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="SpokaneFāVS &raquo; Comments Feed" href="https://spokanefavs.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="SpokaneFāVS &raquo; iCal Feed" href="https://spokanefavs.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="SpokaneFāVS &raquo; ICR on the Road &#8230; and on the Ropes Comments Feed" href="https://spokanefavs.com/icr-on-the-road-and-on-the-ropes/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/spokanefavs.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='embed-pdf-viewer-css'  href='https://spokanefavs.com/wp-content/plugins/embed-pdf-viewer/css/embed-pdf-viewer.css' type='text/css' media='screen' />
<link rel='stylesheet' id='tribe-events-pro-mini-calendar-block-styles-css'  href='https://spokanefavs.com/wp-content/plugins/events-calendar-pro/src/resources/css/tribe-events-pro-mini-calendar-block.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://spokanefavs.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='ct_public_css-css'  href='https://spokanefavs.com/wp-content/plugins/cleantalk-spam-protect/css/cleantalk-public.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='dntplgn_style-css'  href='https://spokanefavs.com/wp-content/plugins/recurring-donation/css/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='jquery_ui_style-css'  href='https://spokanefavs.com/wp-content/plugins/recurring-donation/css/jquery-ui-styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='stripe-handler-ng-style-css'  href='https://spokanefavs.com/wp-content/plugins/stripe-payments/public/assets/css/public.css' type='text/css' media='all' />
<link rel='stylesheet' id='css-wpautbox-tab-css'  href='https://spokanefavs.com/wp-content/plugins/wp-author-box-pro/lib/css/jquery-a-tabs.css' type='text/css' media='all' />
<link rel='stylesheet' id='css-wpautbox-css'  href='https://spokanefavs.com/wp-content/plugins/wp-author-box-pro/lib/css/wpautbox.css' type='text/css' media='all' />
<link rel='stylesheet' id='css-wpautbox-aqua-css'  href='https://spokanefavs.com/wp-content/plugins/wp-author-box-pro/lib/css/aqua.css' type='text/css' media='all' />
<link rel='stylesheet' id='wpautbox-elusive-icon-css'  href='https://spokanefavs.com/wp-content/plugins/wp-author-box-pro/includes/ReduxFramework/ReduxCore/assets/css/vendor/elusive-icons/elusive-icons.css' type='text/css' media='all' />
<link rel='stylesheet' id='yop-public-css'  href='https://spokanefavs.com/wp-content/plugins/yop-poll/public/assets/css/yop-poll-public-6.4.9.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-style-css'  href='https://spokanefavs.com/wp-content/themes/sahifa/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-ilightbox-skin-css'  href='https://spokanefavs.com/wp-content/themes/sahifa/css/ilightbox/dark-skin/skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='Droid+Sans-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media='all' />
<link rel='stylesheet' id='heateor_sssp_frontend_css-css'  href='https://spokanefavs.com/wp-content/plugins/sassy-social-share-premium/public/css/sassy-social-share-premium-public.css' type='text/css' media='all' />
<script type='text/javascript' src='https://spokanefavs.com/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://spokanefavs.com/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script type='text/javascript' id='ct_public_functions-js-extra'>
/* <![CDATA[ */
var ctPublicFunctions = {"_ajax_nonce":"17e076b317","_rest_nonce":"d60dd8fdde","_ajax_url":"\/wp-admin\/admin-ajax.php","_rest_url":"https:\/\/spokanefavs.com\/wp-json\/","data__cookies_type":"native","data__ajax_type":"rest","text__wait_for_decoding":"Decoding the contact data, let us a few seconds to finish. Anti-Spam by CleanTalk.","cookiePrefix":""};
var ctPublic = {"settings__forms__check_internal":"0","settings__forms__check_external":"0","blog_home":"https:\/\/spokanefavs.com\/","pixel__setting":"3","pixel__enabled":"","pixel__url":"https:\/\/moderate9.cleantalk.org\/pixel\/5cc1f75bcadb777344f27d950b420a33.gif","data__email_check_before_post":"1","data__cookies_type":"native","data__visible_fields_required":"1","data__to_local_storage":[]};
/* ]]> */
</script>
<script type='text/javascript' data-cfasync="false" data-pagespeed-no-defer src='https://spokanefavs.com/wp-content/plugins/cleantalk-spam-protect/js/apbct-public-bundle.min.js' id='ct_public_functions-js'></script>
<script type='text/javascript' src='https://spokanefavs.com/wp-includes/js/jquery/ui/core.min.js' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://spokanefavs.com/wp-includes/js/jquery/ui/tabs.min.js' id='jquery-ui-tabs-js'></script>
<script type='text/javascript' src='https://spokanefavs.com/wp-content/plugins/recurring-donation/js/script.js' id='dntplgn_script-js'></script>
<script type='text/javascript' id='yop-public-js-extra'>
/* <![CDATA[ */
var objectL10n = {"yopPollParams":{"urlParams":{"ajax":"https:\/\/spokanefavs.com\/wp-admin\/admin-ajax.php","wpLogin":"https:\/\/spokanefavs.com\/wp-login.php?redirect_to=https%3A%2F%2Fspokanefavs.com%2Fwp-admin%2Fadmin-ajax.php%3Faction%3Dyop_poll_record_wordpress_vote"},"apiParams":{"reCaptcha":{"siteKey":""},"reCaptchaV2Invisible":{"siteKey":""},"reCaptchaV3":{"siteKey":""},"hCaptcha":{"siteKey":""}},"captchaParams":{"imgPath":"https:\/\/spokanefavs.com\/wp-content\/plugins\/yop-poll\/public\/assets\/img\/","url":"https:\/\/spokanefavs.com\/wp-content\/plugins\/yop-poll\/app.php","accessibilityAlt":"Sound icon","accessibilityTitle":"Accessibility option: listen to a question and answer it!","accessibilityDescription":"Type below the <strong>answer<\/strong> to what you hear. Numbers or words:","explanation":"Click or touch the <strong>ANSWER<\/strong>","refreshAlt":"Refresh\/reload icon","refreshTitle":"Refresh\/reload: get new images and accessibility option!"},"voteParams":{"invalidPoll":"Invalid Poll","noAnswersSelected":"No answer selected","minAnswersRequired":"At least {min_answers_allowed} answer(s) required","maxAnswersRequired":"A max of {max_answers_allowed} answer(s) accepted","noAnswerForOther":"No other answer entered","noValueForCustomField":"{custom_field_name} is required","consentNotChecked":"You must agree to our terms and conditions","noCaptchaSelected":"Captcha is required","thankYou":"Thank you for your vote"},"resultsParams":{"singleVote":"vote","multipleVotes":"votes","singleAnswer":"answer","multipleAnswers":"answers"}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://spokanefavs.com/wp-content/plugins/yop-poll/public/assets/js/yop-poll-public-6.4.9.min.js' id='yop-public-js'></script>
<link rel="https://api.w.org/" href="https://spokanefavs.com/wp-json/" /><link rel="alternate" type="application/json" href="https://spokanefavs.com/wp-json/wp/v2/posts/71780" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://spokanefavs.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://spokanefavs.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 6.0.2" />
<link rel='shortlink' href='https://spokanefavs.com/?p=71780' />
<link rel="alternate" type="application/json+oembed" href="https://spokanefavs.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fspokanefavs.com%2Ficr-on-the-road-and-on-the-ropes%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://spokanefavs.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fspokanefavs.com%2Ficr-on-the-road-and-on-the-ropes%2F&#038;format=xml" />

		<!-- GA Google Analytics @ https://m0n.co/ga -->
		<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-50929201-1', 'auto');
			ga('send', 'pageview');
		</script>

	<script type="text/javascript">
  window.MemberfulOptions = {
    site: "https:\/\/spokanefavs.memberful.com",
    memberSignedIn: false  };

  (function() {
    var s = document.createElement('script');
    s.type = 'text/javascript';
    s.async = true;
    s.src = 'https://d35xxde4fgg0cx.cloudfront.net/assets/embedded.js';

    setup = function() { window.MemberfulEmbedded.setup(); };

    s.addEventListener("load", setup, false);

    ( document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0] ).appendChild( s );
  })();
</script>
<style type="text/css">.a-tabs .wpautbox-socials-custom a .wpautbox-icon{ color: #fff;}.a-tabs .wpautbox-socials-custom a:hover .wpautbox-icon{ color: #fff;}.a-tabs .wpautbox-socials-custom a .wpautbox-icon{ background: #333;}.a-tabs .wpautbox-socials-custom a:hover .wpautbox-icon{ background: #222;}.entry-title{
    display:none !important;
}</style><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://spokanefavs.com"><link rel="alternate" href="https://spokanefavs.com/wp-json/tribe/events/v1/" /><link rel="shortcut icon" href="https://spokanefavs.com/wp-content/uploads/2014/08/favicon1.jpg" title="Favicon" />
<!--[if IE]>
<script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script>
<![endif]-->
<!--[if lt IE 9]>
<script src="https://spokanefavs.com/wp-content/themes/sahifa/js/html5.js"></script>
<script src="https://spokanefavs.com/wp-content/themes/sahifa/js/selectivizr-min.js"></script>
<![endif]-->
<!--[if IE 9]>
<link rel="stylesheet" type="text/css" media="all" href="https://spokanefavs.com/wp-content/themes/sahifa/css/ie9.css" />
<![endif]-->
<!--[if IE 8]>
<link rel="stylesheet" type="text/css" media="all" href="https://spokanefavs.com/wp-content/themes/sahifa/css/ie8.css" />
<![endif]-->
<!--[if IE 7]>
<link rel="stylesheet" type="text/css" media="all" href="https://spokanefavs.com/wp-content/themes/sahifa/css/ie7.css" />
<![endif]-->


<meta name="viewport" content="width=device-width, initial-scale=1.0" />

<script data-ad-client="ca-pub-7470048322015446" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<meta name="facebook-domain-verification" content="per9lulhfo19w4mb8dspguj7l7zgmi" />

<!-- MailerLite Universal -->
<script>
    (function(w,d,e,u,f,l,n){w[f]=w[f]||function(){(w[f].q=w[f].q||[])
    .push(arguments);},l=d.createElement(e),l.async=1,l.src=u,
    n=d.getElementsByTagName(e)[0],n.parentNode.insertBefore(l,n);})
    (window,document,'script','https://assets.mailerlite.com/js/universal.js','ml');
    ml('account', '101595');
</script>
<!-- End MailerLite Universal -->


<style type="text/css" media="screen">

body{
	font-family: 'Droid Sans';
}

.page-title{
	font-family: Impact, Charcoal, sans-serif;
	font-size : 30px;
	font-weight: bold;
}

.post-title{
	font-size : 40px;
}

#main-nav,
.cat-box-content,
#sidebar .widget-container,
.post-listing,
#commentform {
	border-bottom-color: #37b8eb;
}

.search-block .search-button,
#topcontrol,
#main-nav ul li.current-menu-item a,
#main-nav ul li.current-menu-item a:hover,
#main-nav ul li.current_page_parent a,
#main-nav ul li.current_page_parent a:hover,
#main-nav ul li.current-menu-parent a,
#main-nav ul li.current-menu-parent a:hover,
#main-nav ul li.current-page-ancestor a,
#main-nav ul li.current-page-ancestor a:hover,
.pagination span.current,
.share-post span.share-text,
.flex-control-paging li a.flex-active,
.ei-slider-thumbs li.ei-slider-element,
.review-percentage .review-item span span,
.review-final-score,
.button,
a.button,
a.more-link,
#main-content input[type="submit"],
.form-submit #submit,
#login-form .login-button,
.widget-feedburner .feedburner-subscribe,
input[type="submit"],
#buddypress button,
#buddypress a.button,
#buddypress input[type=submit],
#buddypress input[type=reset],
#buddypress ul.button-nav li a,
#buddypress div.generic-button a,
#buddypress .comment-reply-link,
#buddypress div.item-list-tabs ul li a span,
#buddypress div.item-list-tabs ul li.selected a,
#buddypress div.item-list-tabs ul li.current a,
#buddypress #members-directory-form div.item-list-tabs ul li.selected span,
#members-list-options a.selected,
#groups-list-options a.selected,
body.dark-skin #buddypress div.item-list-tabs ul li a span,
body.dark-skin #buddypress div.item-list-tabs ul li.selected a,
body.dark-skin #buddypress div.item-list-tabs ul li.current a,
body.dark-skin #members-list-options a.selected,
body.dark-skin #groups-list-options a.selected,
.search-block-large .search-button,
#featured-posts .flex-next:hover,
#featured-posts .flex-prev:hover,
a.tie-cart span.shooping-count,
.woocommerce span.onsale,
.woocommerce-page span.onsale ,
.woocommerce .widget_price_filter .ui-slider .ui-slider-handle,
.woocommerce-page .widget_price_filter .ui-slider .ui-slider-handle,
#check-also-close,
a.post-slideshow-next,
a.post-slideshow-prev,
.widget_price_filter .ui-slider .ui-slider-handle,
.quantity .minus:hover,
.quantity .plus:hover,
.mejs-container .mejs-controls .mejs-time-rail .mejs-time-current,
#reading-position-indicator  {
	background-color:#37b8eb;
}

::-webkit-scrollbar-thumb{
	background-color:#37b8eb !important;
}

#theme-footer,
#theme-header,
.top-nav ul li.current-menu-item:before,
#main-nav .menu-sub-content ,
#main-nav ul ul,
#check-also-box {
	border-top-color: #37b8eb;
}

.search-block:after {
	border-right-color:#37b8eb;
}

body.rtl .search-block:after {
	border-left-color:#37b8eb;
}

#main-nav ul > li.menu-item-has-children:hover > a:after,
#main-nav ul > li.mega-menu:hover > a:after {
	border-color:transparent transparent #37b8eb;
}

.widget.timeline-posts li a:hover,
.widget.timeline-posts li a:hover span.tie-date {
	color: #37b8eb;
}

.widget.timeline-posts li a:hover span.tie-date:before {
	background: #37b8eb;
	border-color: #37b8eb;
}

#order_review,
#order_review_heading {
	border-color: #37b8eb;
}


body {
	background-image : url(https://spokanefavs.com/wp-content/themes/sahifa/images/patterns/body-bg3.png);
	background-position: top center;
}

a {
	color: #259ce6;
}
		
</style>

		<script type="text/javascript">
			/* <![CDATA[ */
				var sf_position = '0';
				var sf_templates = "<a href=\"{search_url_escaped}\">View All Results<\/a>";
				var sf_input = '.search-live';
				jQuery(document).ready(function(){
					jQuery(sf_input).ajaxyLiveSearch({"expand":false,"searchUrl":"https:\/\/spokanefavs.com\/?s=%s","text":"Search","delay":500,"iwidth":180,"width":315,"ajaxUrl":"https:\/\/spokanefavs.com\/wp-admin\/admin-ajax.php","rtl":0});
					jQuery(".live-search_ajaxy-selective-input").keyup(function() {
						var width = jQuery(this).val().length * 8;
						if(width < 50) {
							width = 50;
						}
						jQuery(this).width(width);
					});
					jQuery(".live-search_ajaxy-selective-search").click(function() {
						jQuery(this).find(".live-search_ajaxy-selective-input").focus();
					});
					jQuery(".live-search_ajaxy-selective-close").click(function() {
						jQuery(this).parent().remove();
					});
				});
			/* ]]> */
		</script>
		
<!-- Meta Pixel Code -->
<script type='text/javascript'>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
</script>
<!-- End Meta Pixel Code -->
<script type='text/javascript'>
  fbq('init', '2279624612345007', {}, {
    "agent": "wordpress-6.0.2-3.0.7"
});
  </script><script type='text/javascript'>
  fbq('track', 'PageView', []);
  </script>
<!-- Meta Pixel Code -->
<noscript>
<img height="1" width="1" style="display:none" alt="fbpx"
src="https://www.facebook.com/tr?id=2279624612345007&ev=PageView&noscript=1" />
</noscript>
<!-- End Meta Pixel Code -->
<link rel="icon" href="https://spokanefavs.com/wp-content/uploads/2019/06/cropped-Spokane-FAVS_logo-copy-e1561920891212-32x32.png" sizes="32x32" />
<link rel="icon" href="https://spokanefavs.com/wp-content/uploads/2019/06/cropped-Spokane-FAVS_logo-copy-e1561920891212-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://spokanefavs.com/wp-content/uploads/2019/06/cropped-Spokane-FAVS_logo-copy-e1561920891212-180x180.png" />
<meta name="msapplication-TileImage" content="https://spokanefavs.com/wp-content/uploads/2019/06/cropped-Spokane-FAVS_logo-copy-e1561920891212-270x270.png" />
</head>
<body id="top" class="post-template-default single single-post postid-71780 single-format-standard tribe-no-js lazy-enabled tribe-theme-sahifa">

<div class="wrapper-outer">

	<div class="background-cover"></div>

	<aside id="slide-out">

			<div class="search-mobile">
			<form method="get" id="searchform-mobile" action="https://spokanefavs.com/">
				<button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button>
				<input type="text" id="s-mobile" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  />
			</form>
		</div><!-- .search-mobile /-->
	
			<div class="social-icons">
		<a class="ttip-none" title="Rss" href="https://spokanefavs.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="https://www.facebook.com/SpokaneFAVS/" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="https://twitter.com/spokanefavs" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/spokanefavs/" target="_blank"><i class="fa fa-instagram"></i></a>
			</div>

	
		<div id="mobile-menu" ></div>
	</aside><!-- #slide-out /-->

		<div id="wrapper" class="boxed">
		<div class="inner-wrapper">

		<header id="theme-header" class="theme-header">
						<div id="top-nav" class="top-nav">
				<div class="container">

			
				<div class="top-menu"><ul id="menu-top" class="menu"><li id="menu-item-54121" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-54121"><a href="https://spokanefavs.com/">HOME</a></li>
<li id="menu-item-54026" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54026"><a href="https://spokanefavs.com/category/news/">News</a></li>
<li id="menu-item-54027" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-54027"><a href="https://spokanefavs.com/category/commentary/">Commentary</a>
<ul class="sub-menu">
	<li id="menu-item-54122" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54122"><a href="https://spokanefavs.com/ask/">ASK</a></li>
</ul>
</li>
<li id="menu-item-54044" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54044"><a href="http://spokanefavs.com/events/">Calendar</a></li>
<li id="menu-item-54032" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54032"><a href="https://spokanefavs.com/coffee-talk/">Coffee Talk</a></li>
<li id="menu-item-54029" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-54029"><a href="https://spokanefavs.com/about/">About</a>
<ul class="sub-menu">
	<li id="menu-item-54033" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54033"><a href="https://spokanefavs.com/about/formation-board/">Board of Trustees</a></li>
	<li id="menu-item-69319" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69319"><a href="https://spokanefavs.com/writers/reporters/">Reporters</a></li>
	<li id="menu-item-54047" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54047"><a href="https://spokanefavs.com/writers/contributors/">Columnists</a></li>
	<li id="menu-item-54040" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54040"><a href="https://spokanefavs.com/about/staff/">Staff</a></li>
	<li id="menu-item-54035" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54035"><a href="https://spokanefavs.com/about/contact/">Contact</a></li>
	<li id="menu-item-54036" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54036"><a href="https://spokanefavs.com/about/editorial-independence-policy/">Editorial Independence Policy</a></li>
	<li id="menu-item-54037" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54037"><a href="https://spokanefavs.com/about/fundraising-and-donor-policy/">Fundraising and Donor Policy</a></li>
	<li id="menu-item-54038" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54038"><a href="https://spokanefavs.com/about/privacy-policy/">Privacy Policy</a></li>
	<li id="menu-item-54034" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54034"><a href="https://spokanefavs.com/about/comment-policy/">Comment Policy</a></li>
	<li id="menu-item-54041" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54041"><a href="https://spokanefavs.com/about/user-agreement/">User Agreement</a></li>
	<li id="menu-item-54039" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54039"><a href="https://spokanefavs.com/about/sitemap/">Sitemap</a></li>
</ul>
</li>
<li id="menu-item-54030" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-54030"><a href="https://spokanefavs.com/support-us/">Support Us</a>
<ul class="sub-menu">
	<li id="menu-item-54042" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54042"><a href="https://spokanefavs.com/advertise/">Advertise</a></li>
</ul>
</li>
<li id="menu-item-60347" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60347"><a href="https://spokanefavs.com/spokane-members/">FāVS Members</a></li>
</ul></div>
						<div class="search-block">
						<form method="get" id="searchform-header" action="https://spokanefavs.com/">
							<button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button>
							<input class="search-live" type="text" id="s-header" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  />
						</form>
					</div><!-- .search-block /-->
			<div class="social-icons">
		<a class="ttip-none" title="Rss" href="https://spokanefavs.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="https://www.facebook.com/SpokaneFAVS/" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="https://twitter.com/spokanefavs" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/spokanefavs/" target="_blank"><i class="fa fa-instagram"></i></a>
			</div>

	
	
				</div><!-- .container /-->
			</div><!-- .top-menu /-->
			
		<div class="header-content">

					<a id="slide-out-open" class="slide-out-open" href="#"><span></span></a>
		
			<div class="logo" style=" margin-top:15px; margin-bottom:15px;">
			<h2>								<a title="SpokaneFāVS" href="https://spokanefavs.com/">
					<img src="https://spokanefavs.com/wp-content/uploads/2019/06/Spokane-FAVS_logo-copy.png" alt="SpokaneFāVS"  /><strong>SpokaneFāVS </strong>
				</a>
			</h2>			</div><!-- .logo /-->
						<div class="clear"></div>

		</div>
													<nav id="main-nav" class="fixed-enabled">
				<div class="container">

				
					<div class="main-menu"><ul id="menu-top-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-54121"><a href="https://spokanefavs.com/">HOME</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54026"><a href="https://spokanefavs.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-54027"><a href="https://spokanefavs.com/category/commentary/">Commentary</a>
<ul class="sub-menu menu-sub-content">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54122"><a href="https://spokanefavs.com/ask/">ASK</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54044"><a href="http://spokanefavs.com/events/">Calendar</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54032"><a href="https://spokanefavs.com/coffee-talk/">Coffee Talk</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-54029"><a href="https://spokanefavs.com/about/">About</a>
<ul class="sub-menu menu-sub-content">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54033"><a href="https://spokanefavs.com/about/formation-board/">Board of Trustees</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69319"><a href="https://spokanefavs.com/writers/reporters/">Reporters</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54047"><a href="https://spokanefavs.com/writers/contributors/">Columnists</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54040"><a href="https://spokanefavs.com/about/staff/">Staff</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54035"><a href="https://spokanefavs.com/about/contact/">Contact</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54036"><a href="https://spokanefavs.com/about/editorial-independence-policy/">Editorial Independence Policy</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54037"><a href="https://spokanefavs.com/about/fundraising-and-donor-policy/">Fundraising and Donor Policy</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54038"><a href="https://spokanefavs.com/about/privacy-policy/">Privacy Policy</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54034"><a href="https://spokanefavs.com/about/comment-policy/">Comment Policy</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54041"><a href="https://spokanefavs.com/about/user-agreement/">User Agreement</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54039"><a href="https://spokanefavs.com/about/sitemap/">Sitemap</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-54030"><a href="https://spokanefavs.com/support-us/">Support Us</a>
<ul class="sub-menu menu-sub-content">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54042"><a href="https://spokanefavs.com/advertise/">Advertise</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60347"><a href="https://spokanefavs.com/spokane-members/">FāVS Members</a></li>
</ul></div>										<a href="https://spokanefavs.com/?tierand=1" class="random-article ttip" title="Random Article"><i class="fa fa-random"></i></a>
					
					
				</div>
			</nav><!-- .main-nav /-->
					</header><!-- #header /-->

	
	
	<div id="main-content" class="container">

	
	
	
	
	
	<div class="content">

		
		<nav id="crumbs"><a href="https://spokanefavs.com/"><span class="fa fa-home" aria-hidden="true"></span> Home</a><span class="delimiter">/</span><a href="https://spokanefavs.com/category/commentary/">Commentary</a><span class="delimiter">/</span><span class="current">ICR on the Road &#8230; and on the Ropes</span></nav><script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"BreadcrumbList","@id":"#Breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"name":"Home","@id":"https:\/\/spokanefavs.com\/"}},{"@type":"ListItem","position":2,"item":{"name":"Commentary","@id":"https:\/\/spokanefavs.com\/category\/commentary\/"}}]}</script>
		

		
		<article class="post-listing post-71780 post type-post status-publish format-standard has-post-thumbnail  category-commentary tag-answers-in-genesis tag-creation-vs-evolution tag-institute-of-creation-research tag-natural-selection tag-young-earth-creation" id="the-post">
			
			<div class="single-post-thumb">
			<img width="650" height="330" src="https://spokanefavs.com/wp-content/uploads/2022/10/Creationism-vs.-Evolution-650x330.png" class="attachment-slider size-slider wp-post-image" alt="" />		</div>
	
		<div class="single-post-caption">Creationism vs. evolution / Photo by Maridav (Depositphotos)</div> 


			<div class="post-inner">

							<h1 class="name post-title entry-title"><span itemprop="name">ICR on the Road &#8230; and on the Ropes</span></h1>

						
<p class="post-meta">
		
	<span class="post-meta-author"><i class="fa fa-user"></i><a href="https://spokanefavs.com/author/jimd/" title="">Jim Downard </a></span>
	
		
	<span class="tie-date"><i class="fa fa-clock-o"></i>11 hours ago</span>	
	<span class="post-cats"><i class="fa fa-folder"></i><a href="https://spokanefavs.com/category/commentary/" rel="category tag">Commentary</a></span>
	
	<span class="post-comments"><i class="fa fa-comments"></i><a href="https://spokanefavs.com/icr-on-the-road-and-on-the-ropes/#disqus_thread"><span class="dsq-postid" data-dsqidentifier="71780 https://spokanefavs.com/?p=71780">Leave a comment</span></a></span>
<span class="post-views"><i class="fa fa-eye"></i>134 Views</span> </p>
<div class="clear"></div>
			
				<div class="entry">
					
					
					<div class='heateorSsspClear'></div><div  class='heateor_sssp_sharing_container heateor_sssp_horizontal_sharing' data-heateor-sssp-href='https://spokanefavs.com/icr-on-the-road-and-on-the-ropes/'><div class='heateor_sssp_sharing_title' style="font-weight:bold" >Share this story!</div><div class= "heateor_sssp_sharing_ul"><a class="heateor_sssp_facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fspokanefavs.com%2Ficr-on-the-road-and-on-the-ropes%2F" title="Facebook" rel="nofollow noopener" target="_blank" style="font-size:24px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class= "heateor_sssp_square_count heateor_sssp_facebook_count">&nbsp;</span><span class="heateor_sssp_svg" style="background-color:#3c589a;width:26px;height:26px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:24px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-5 -5 42 42"><path class="heateor_sssp_logo" d="M17.78 27.5V17.008h3.522l.527-4.09h-4.05v-2.61c0-1.182.33-1.99 2.023-1.99h2.166V4.66c-.375-.05-1.66-.16-3.155-.16-3.123 0-5.26 1.905-5.26 5.405v3.016h-3.53v4.09h3.53V27.5h4.223z" fill="#fff"></path></svg></span></a><a class="heateor_sssp_button_twitter" href="http://twitter.com/intent/tweet?via=spokanefavs&text=ICR%20on%20the%20Road%20...%20and%20on%20the%20Ropes&url=https%3A%2F%2Fspokanefavs.com%2Ficr-on-the-road-and-on-the-ropes%2F" title="Twitter" rel="nofollow noopener" target="_blank" style="font-size:24px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class= "heateor_sssp_square_count heateor_sssp_twitter_count">&nbsp;</span><span class="heateor_sssp_svg heateor_sssp_s__default heateor_sssp_s_twitter" style="background-color:#55acee;width:26px;height:26px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:24px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-4 -4 39 39"><path class="heateor_sssp_logo" d="M28 8.557a9.913 9.913 0 0 1-2.828.775 4.93 4.93 0 0 0 2.166-2.725 9.738 9.738 0 0 1-3.13 1.194 4.92 4.92 0 0 0-3.593-1.55 4.924 4.924 0 0 0-4.794 6.049c-4.09-.21-7.72-2.17-10.15-5.15a4.942 4.942 0 0 0-.665 2.477c0 1.71.87 3.214 2.19 4.1a4.968 4.968 0 0 1-2.23-.616v.06c0 2.39 1.7 4.38 3.952 4.83-.414.115-.85.174-1.297.174-.318 0-.626-.03-.928-.086a4.935 4.935 0 0 0 4.6 3.42 9.893 9.893 0 0 1-6.114 2.107c-.398 0-.79-.023-1.175-.068a13.953 13.953 0 0 0 7.55 2.213c9.056 0 14.01-7.507 14.01-14.013 0-.213-.005-.426-.015-.637.96-.695 1.795-1.56 2.455-2.55z" fill="#fff"></path></svg></span></a><a class="heateor_sssp_button_reddit" href="http://reddit.com/submit?url=https%3A%2F%2Fspokanefavs.com%2Ficr-on-the-road-and-on-the-ropes%2F&title=ICR%20on%20the%20Road%20...%20and%20on%20the%20Ropes" title="Reddit" rel="nofollow noopener" target="_blank" style="font-size:24px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class= "heateor_sssp_square_count heateor_sssp_reddit_count">&nbsp;</span><span class="heateor_sssp_svg heateor_sssp_s__default heateor_sssp_s_reddit" style="background-color:#ff5700;width:26px;height:26px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:24px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-3.5 -3.5 39 39"><path class="heateor_sssp_logo" d="M28.543 15.774a2.953 2.953 0 0 0-2.951-2.949 2.882 2.882 0 0 0-1.9.713 14.075 14.075 0 0 0-6.85-2.044l1.38-4.349 3.768.884a2.452 2.452 0 1 0 .24-1.176l-4.274-1a.6.6 0 0 0-.709.4l-1.659 5.224a14.314 14.314 0 0 0-7.316 2.029 2.908 2.908 0 0 0-1.872-.681 2.942 2.942 0 0 0-1.618 5.4 5.109 5.109 0 0 0-.062.765c0 4.158 5.037 7.541 11.229 7.541s11.22-3.383 11.22-7.541a5.2 5.2 0 0 0-.053-.706 2.963 2.963 0 0 0 1.427-2.51zm-18.008 1.88a1.753 1.753 0 0 1 1.73-1.74 1.73 1.73 0 0 1 1.709 1.74 1.709 1.709 0 0 1-1.709 1.711 1.733 1.733 0 0 1-1.73-1.711zm9.565 4.968a5.573 5.573 0 0 1-4.081 1.272h-.032a5.576 5.576 0 0 1-4.087-1.272.6.6 0 0 1 .844-.854 4.5 4.5 0 0 0 3.238.927h.032a4.5 4.5 0 0 0 3.237-.927.6.6 0 1 1 .844.854zm-.331-3.256a1.726 1.726 0 1 1 1.709-1.712 1.717 1.717 0 0 1-1.712 1.712z" fill="#fff"/></svg></span></a><a class="heateor_sssp_button_linkedin" href="http://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fspokanefavs.com%2Ficr-on-the-road-and-on-the-ropes%2F&title=ICR%20on%20the%20Road%20...%20and%20on%20the%20Ropes" title="Linkedin" rel="nofollow noopener" target="_blank" style="font-size:24px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class= "heateor_sssp_square_count heateor_sssp_linkedin_count">&nbsp;</span><span class="heateor_sssp_svg heateor_sssp_s__default heateor_sssp_s_linkedin" style="background-color:#0077b5;width:26px;height:26px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:24px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="0 0 32 32"><path d="M6.227 12.61h4.19v13.48h-4.19V12.61zm2.095-6.7a2.43 2.43 0 0 1 0 4.86c-1.344 0-2.428-1.09-2.428-2.43s1.084-2.43 2.428-2.43m4.72 6.7h4.02v1.84h.058c.56-1.058 1.927-2.176 3.965-2.176 4.238 0 5.02 2.792 5.02 6.42v7.395h-4.183v-6.56c0-1.564-.03-3.574-2.178-3.574-2.18 0-2.514 1.7-2.514 3.46v6.668h-4.187V12.61z" fill="#fff"></path></svg></span></a><a class="heateor_sssp_button_email" title="Email" rel="nofollow noopener" target="_blank" onclick="window.open('mailto:?subject=' + decodeURIComponent('ICR%20on%20the%20Road%20...%20and%20on%20the%20Ropes' ).replace('&', '%26') + '&body= ' + decodeURIComponent('https%3A%2F%2Fspokanefavs.com%2Ficr-on-the-road-and-on-the-ropes%2F'))" style="font-size:24px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class= "heateor_sssp_square_count heateor_sssp_email_count">&nbsp;</span><span class="heateor_sssp_svg heateor_sssp_s__default heateor_sssp_s_email" style="background-color:#649a3f;width:26px;height:26px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:24px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-4 -4 43 43"><path d="M 5.5 11 h 23 v 1 l -11 6 l -11 -6 v -1 m 0 2 l 11 6 l 11 -6 v 11 h -22 v -11" stroke-width="1" fill="#fff"></path></svg></span></a><a class="heateor_sssp_button_facebook_messenger" title="Facebook Messenger" rel="nofollow noopener" target="_blank" href="https://www.facebook.com/dialog/send?app_id=1904103319867886&display=popup&link=https%3A%2F%2Fspokanefavs.com%2Ficr-on-the-road-and-on-the-ropes%2F&redirect_uri=https%3A%2F%2Fspokanefavs.com%2Ficr-on-the-road-and-on-the-ropes%2F" style="font-size:24px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class= "heateor_sssp_square_count heateor_sssp_Facebook_Messenger_count">&nbsp;</span><span class="heateor_sssp_svg heateor_sssp_s__default heateor_sssp_s_facebook_messenger" style="background-color:#0084ff;width:26px;height:26px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:24px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-2 -2 36 36"><path fill="#fff" d="M16 5C9.986 5 5.11 9.56 5.11 15.182c0 3.2 1.58 6.054 4.046 7.92V27l3.716-2.06c.99.276 2.04.425 3.128.425 6.014 0 10.89-4.56 10.89-10.183S22.013 5 16 5zm1.147 13.655L14.33 15.73l-5.423 3 5.946-6.31 2.816 2.925 5.42-3-5.946 6.31z"/></svg></span></a><a class="heateor_sssp_button_pocket" href="https://getpocket.com/edit?url=https%3A%2F%2Fspokanefavs.com%2Ficr-on-the-road-and-on-the-ropes%2F&title=ICR%20on%20the%20Road%20...%20and%20on%20the%20Ropes" title="Pocket" rel="nofollow noopener" target="_blank" style="font-size:24px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class= "heateor_sssp_square_count heateor_sssp_Pocket_count">&nbsp;</span><span class="heateor_sssp_svg heateor_sssp_s__default heateor_sssp_s_pocket" style="background-color:#ee4056;width:26px;height:26px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:24px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="0 0 32 32"><path fill="#fff" d="M16.005 6.244c2.927 0 5.854-.002 8.782 0 1.396.002 2.195.78 2.188 2.165-.015 2.483.116 4.985-.11 7.454-.75 8.204-10.027 12.607-16.91 8.064-3.086-2.037-4.82-4.926-4.917-8.673-.06-2.34-.034-4.684-.018-7.025.008-1.214.812-1.98 2.056-1.983 2.975-.01 5.952-.005 8.93-.007zm-5.037 5.483c-.867.093-1.365.396-1.62 1.025-.27.67-.078 1.256.417 1.732a529.74 529.74 0 0 0 5.09 4.838c.745.695 1.537.687 2.278-.01a473.74 473.74 0 0 0 4.93-4.686c.827-.797.91-1.714.252-2.38-.694-.704-1.583-.647-2.447.17-1.097 1.04-2.215 2.06-3.266 3.143-.485.492-.77.432-1.227-.027a87.392 87.392 0 0 0-3.39-3.225c-.325-.29-.77-.448-1.017-.584z"></path></svg></span></a><a class="heateor_sssp_button_instagram" href="https://www.instagram.com/" title="Instagram" rel="nofollow noopener" target="_blank" style="font-size:24px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class= "heateor_sssp_square_count heateor_sssp_instagram_count">&nbsp;</span><span class="heateor_sssp_svg" style="background-color:#53beee;width:26px;height:26px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:24px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" id="Layer_1" version="1.1" viewBox="-10 -10 148 148" width="100%" height="100%" xml:space="preserve" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><g><g><path d="M86,112H42c-14.336,0-26-11.663-26-26V42c0-14.337,11.664-26,26-26h44c14.337,0,26,11.663,26,26v44 C112,100.337,100.337,112,86,112z M42,24c-9.925,0-18,8.074-18,18v44c0,9.925,8.075,18,18,18h44c9.926,0,18-8.075,18-18V42 c0-9.926-8.074-18-18-18H42z" fill="#fff"></path></g><g><path d="M64,88c-13.234,0-24-10.767-24-24c0-13.234,10.766-24,24-24s24,10.766,24,24C88,77.233,77.234,88,64,88z M64,48c-8.822,0-16,7.178-16,16s7.178,16,16,16c8.822,0,16-7.178,16-16S72.822,48,64,48z" fill="#fff"></path></g><g><circle cx="89.5" cy="38.5" fill="#fff" r="5.5"></circle></g></g></svg></span></a><a class="heateor_sssp_button_print" onclick="window.print()" style="font-size:24px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class= "heateor_sssp_square_count heateor_sssp_print_count">&nbsp;</span><span class="heateor_sssp_svg heateor_sssp_s__default heateor_sssp_s_print" style="background-color:#fd6500;width:26px;height:26px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:24px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="0 0 32 32"><path fill="#fff" stroke="#fff" stroke-width=".1" d="M4.467 14.305h23.065v6.498H4.467v-6.498z"/><path fill="#fff" stroke="#fff" stroke-width=".1" d="M5.228 12.83H26.77l.745 1.39H4.485l.743-1.39z"/><path d="M9.19 8.118h13.467v6.106H9.19z"/><path fill="#fff" stroke="#fff" stroke-width=".1" d="M9.844 6.516h12.312v7.31H9.844z"/><path stroke="#fff" stroke-width=".1" d="M8.602 17.37h14.574v3.396H8.602z"/><path fill="#fff" stroke="#fff" stroke-width=".1" d="M10.152 17.97h11.27l2.233 7.515H7.92l2.232-7.514z"/></svg></span></a><a class="heateor_sssp_button_sms" href="sms:?&body=ICR%20on%20the%20Road%20...%20and%20on%20the%20Ropes https%3A%2F%2Fspokanefavs.com%2Ficr-on-the-road-and-on-the-ropes%2F" title="SMS" rel="nofollow noopener" style="font-size:24px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class= "heateor_sssp_square_count heateor_sssp_SMS_count">&nbsp;</span><span class="heateor_sssp_svg heateor_sssp_s__default heateor_sssp_s_sms" style="background-color:#6ebe45;width:26px;height:26px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:24px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="0 0 32 32"><path fill="#fff" d="M16 3.543c-7.177 0-13 4.612-13 10.294 0 3.35 2.027 6.33 5.16 8.21 1.71 1.565 1.542 4.08-.827 6.41 2.874 0 7.445-1.698 8.462-4.34H16c7.176 0 13-4.605 13-10.285s-5.824-10.29-13-10.29zM9.045 17.376c-.73 0-1.45-.19-1.81-.388l.294-1.194c.384.2.98.398 1.6.398.66 0 1.01-.275 1.01-.692 0-.398-.302-.625-1.07-.9-1.06-.37-1.753-.957-1.753-1.886 0-1.09.91-1.924 2.415-1.924.72 0 1.25.152 1.63.322l-.322 1.166a3.037 3.037 0 0 0-1.336-.303c-.625 0-.93.284-.93.616 0 .41.36.59 1.186.9 1.127.42 1.658 1.01 1.658 1.91.003 1.07-.822 1.98-2.575 1.98zm9.053-.095l-.095-2.44a72.993 72.993 0 0 1-.057-2.626h-.028a35.41 35.41 0 0 1-.71 2.475l-.778 2.49h-1.128l-.682-2.473a29.602 29.602 0 0 1-.578-2.493h-.02c-.037.863-.065 1.85-.112 2.645l-.114 2.425H12.46l.407-6.386h1.924l.63 2.13c.2.74.397 1.536.54 2.285h.027a52.9 52.9 0 0 1 .607-2.293l.683-2.12h1.886l.35 6.386H18.1zm4.09.1c-.73 0-1.45-.19-1.81-.39l.293-1.194c.39.2.99.398 1.605.398.663 0 1.014-.275 1.014-.692 0-.396-.305-.623-1.07-.9-1.064-.37-1.755-.955-1.755-1.884 0-1.09.91-1.924 2.416-1.924.72 0 1.25.153 1.63.323l-.322 1.166a3.038 3.038 0 0 0-1.337-.303c-.625 0-.93.284-.93.616 0 .408.36.588 1.186.9 1.127.42 1.658 1.006 1.658 1.906.002 1.07-.823 1.98-2.576 1.98z"></path></svg></span></a><a class="heateor_sssp_button_pinterest" onclick="javascript:void( (function() {var e=document.createElement('script' );e.setAttribute('type','text/javascript' );e.setAttribute('charset','UTF-8' );e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e)})());" title="Pinterest" rel="nofollow noopener" target="_blank" style="font-size:24px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class= "heateor_sssp_square_count heateor_sssp_pinterest_count">&nbsp;</span><span class="heateor_sssp_svg heateor_sssp_s__default heateor_sssp_s_pinterest" style="background-color:#cc2329;width:26px;height:26px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:24px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-2 -2 35 35"><path fill="#fff" d="M16.539 4.5c-6.277 0-9.442 4.5-9.442 8.253 0 2.272.86 4.293 2.705 5.046.303.125.574.005.662-.33.061-.231.205-.816.27-1.06.088-.331.053-.447-.191-.736-.532-.627-.873-1.439-.873-2.591 0-3.338 2.498-6.327 6.505-6.327 3.548 0 5.497 2.168 5.497 5.062 0 3.81-1.686 7.025-4.188 7.025-1.382 0-2.416-1.142-2.085-2.545.397-1.674 1.166-3.48 1.166-4.689 0-1.081-.581-1.983-1.782-1.983-1.413 0-2.548 1.462-2.548 3.419 0 1.247.421 2.091.421 2.091l-1.699 7.199c-.505 2.137-.076 4.755-.039 5.019.021.158.223.196.314.077.13-.17 1.813-2.247 2.384-4.324.162-.587.929-3.631.929-3.631.46.876 1.801 1.646 3.227 1.646 4.247 0 7.128-3.871 7.128-9.053.003-3.918-3.317-7.568-8.361-7.568z"/></svg></span></a><a class="heateor_sssp_more" title="More" href="https://spokanefavs.com/icr-on-the-road-and-on-the-ropes/" onclick="event.preventDefault()" rel="nofollow noopener" target="_blank" style="font-size: 24px!important;border:0;box-shadow:none;display:inline-block!important;padding:0 4px;vertical-align: middle;display:inline;"><span class= "heateor_sssp_square_count">&nbsp;</span><span class="heateor_sssp_svg" style="background-color:#ee8e2d;width:26px;height:26px;border-radius:999px;display:inline-block!important;opacity:1;float:left;font-size:24px!important;box-shadow:none;display:inline-block;padding:0 4px;vertical-align:middle;display:inline;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box;" onclick= "heateorSsspMoreSharingPopup(this, 'https://spokanefavs.com/icr-on-the-road-and-on-the-ropes/', 'ICR%20on%20the%20Road%20...%20and%20on%20the%20Ropes', '' )"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" viewBox="-.3 0 32 32" version="1.1" width="100%" height="100%" style="display:block;border-radius:999px;" xml:space="preserve"><g><path fill="#fff" d="M18 14V8h-4v6H8v4h6v6h4v-6h6v-4h-6z" fill-rule="evenodd"></path></g></svg></span></a><a style="font-size:24px!important;box-shadow:none;display:inline-block;vertical-align:middle;" class="heateorSsspTotalShares heateorSsspSharingRound"><span class= "heateor_sssp_square_count">&nbsp;</span><div style="width:26px;height:26px;border-radius:999px;margin-left:9px !important;" title="Total Shares" class="heateorSsspSharing heateorSsspTCBackground"></div></a></div></div><div class='heateorSsspClear'></div>
<h2 id="h-icr-on-the-road-and-on-the-ropes">ICR on the Road &#8230; and on the Ropes</h2>



<p><strong>Commentary By <a href="https://spokanefavs.com/author/jimd/">Jim Downard</a></strong></p>



<p>The <a href="http://www.icr.org/">Institute for Creation Research</a> (ICR), one of the oldest creationist organizations (roughly the same age as color television and jet airliners) has been eclipsed in the young earth creation (YEC) propaganda parade by the more glitzy <a href="https://answersingenesis.org/">Answers in Genesis</a> of Ken Ham, the bunch with Ark Encounter, a Noah’s ark theme park.</p>



<p>But ICR isn’t out of the game, no siree, engaging in a steady routine of lecture events held at congenial churches around the land. <a href="https://spokanefavs.com/young-earth-creation-conference-comes-to-spokane-to-talk-lifes-origins/">Spokane got on the itinerary for one</a> this weekend, and it’s worth a look at the speakers and what might not get on their lecture notes. Or their resumes, as all three are presented as “Dr.” this or that, though that might mislead one to think that their degrees are in relevant scientific fields and from reliable institutions.</p>



<p>Star of the show is ICR’s President, Randy Guliuzza, who is a medical doctor and former Air Force flight surgeon. Taking command of ICR in 2020, his big mission is driving a wedge into the flock with his relentless rejection of natural selection (something all too observable in the natural world and in the science literature Randy doesn’t read much of).</p>



<p>Instead, Guliuzza’s baby is continuous environmental tracking (CET), which spin he and a few colleagues present in a plethora of articles in their in-house magazine, <em>Acts &amp; Facts</em>, and elsewhere.</p>



<p>Spoiler Alert: CET is so poorly supported that not only do regular biologists pay no attention to it whatsoever, fellow-creationist astrophysicist Jason Lisle has severed his connections with ICR over it. Biology professor — and actual “Dr.” — Joel Duff, who keeps track of such things, offered some <a href="https://www.youtube.com/watch?v=WujtvGRg6RM">pithy analysis of this last July on YouTube</a>.</p>



<p>The other two speakers are Frank Sherwin, who has an honorary doctorate of science from Pensacola Christian College, and Tim Clarey, the only one among them with a relevant degree, a doctorate in geology from Western Michigan University. Though given his output, he might want to ask for his tuition back.</p>



<p>Clarey is adroit at selectively parsing secular science works to favor the YEC model. I’ve done several of my “Evolution Hour” shows on his misrepresentation of science papers, and this <a href="https://www.youtube.com/watch?v=rB_XesrBWQo">2018 show on the “cold slab” claim</a> will give you the basic idea about how badly he plays the source documentation game. (Full reference links are in the video description.)</p>



<p>Clarey represents another sore point in YEC land, which may not come up in the Spokane show: <em>when</em> the flood is supposed to have stopped in the geological record.</p>



<p>He is among the small body of revisionists who try and nudge the flood terminal point down way past where most YECers are comfortable locating it (the dinosaur Cretaceous) on into our more recent Cenozoic era, because it’s hard to argue the strata there are formed in any way noticeably different than any of the preceding stuff. All or nothing for them, alas.</p>



<p>The bulk of the ICR show’s topics are being carried by Clarey and Sherwin, presenting the current line on things already covered at grim length in their publications. Here’s what you’d learn at the ICR website (sparing you the price of admission to their roadshow).</p>



<p>Dinosaurs must not be related to birds and died out in the flood 4,300 years ago, except for the ones that survived for human artists supposedly to depict in paintings, into the Middle Ages even. And somehow these critters are related to the biblical behemoth and leviathan.</p>



<p>Mount St. Helens will be discussed, as a baby cataclysm to justify their wacky mega-cataclysm of the flood. As someone who shoveled volcanic ash off the driveway in 1980 and has kept up on the geology of the volcano and region since then, having creationists try to bring them up in our own backyard deserves points for gutsiness.</p>



<p>To summarize in a nutshell (accent on the nut), creationism has two main songs: “Origins or Bust” about life itself or aspects of it being impossible other than via divine creation, and “Gee Whiz” stuff marveling at the amazing (fill in the blank) but not going too far into whatever science literature there may be on them, especially their evolutionary history.</p>



<p>We’ll leave with something from honorary doctor Sherwin.</p>



<p>As it happened, this Halloween I planned to discuss one of Sherwin’s older articles in my video talks, one he did in 2012 with Brian Thomas <a href="https://www.icr.org/article/hybrid-sharks-evolutionary-storytelling/">on hybrid sharks supposedly posing a problem for evolution</a>.</p>



<p>They didn’t draw on much science work (mostly general books and creationist posts), but what they did, they bungled. They declared, “Evolutionists are mystified as to the origin of sharks (as well as all other animal groups) and their associated structures,” for example, citing <a href="https://www.researchgate.net/publication/6617685_Palaeontology_-_Embryonic_identity_crisis">a secondary article from 2007</a> that hadn’t mentioned sharks at all,</p>



<p>It was actually a commentary piece about identifying whether some Neoproterozoic embryos were animals or not. That’s a time some 600 million years ago, which in the YEC cartoon is pre-flood, creation week stuff. Only Sherwin and Thomas are like other creationists in not being all that clear about their YEC model, grabbing at this or that and waving it at an audience unlikely to know much about them, and even less likely to look into things at the source level.</p>



<p>Still, the PowerPoint images were probably nice and the presentations confident, and maybe they’ll have made a bit on the admission fees and special lectures (at extra cost). But nothing about it will have changed any of the scientific landscape, or bring ICR any closer to having the bigger world jump on their very small bandwagon.</p>
<div id="wpautbox-634cbad8a1f4b" class="wpautbox-below"><input type="hidden" class="wpautbox-input-authorid" value="733" /><ul class="a-tab-nav"><li class="a-tab-active"><a href="#wpautbox_about"><i class="el-icon-user wpautbox-icon"></i> About the Author</a></li><li><a href="#wpautbox_latest-post"><i class="el-icon-list wpautbox-icon"></i> Latest Posts</a></li></ul><div class="a-tab-container"><div class="a-tab-content" id="wpautbox_about"><div class="wpautbox-avatar wpautbox-avatar-circle"><a href="https://spokanefavs.com/author/jimd/"><img alt='' src='https://spokanefavs.com/wp-content/uploads/2013/04/SPO_jim_downard-120x120.jpg' srcset='https://spokanefavs.com/wp-content/uploads/2013/04/SPO_jim_downard.jpg 2x' class='avatar avatar-120 photo' height='120' width='120' loading='lazy'/></a></div><div class="wpautbox-author-meta"><h4 class="wpautbox-name"><span>About</span> <a href="https://spokanefavs.com/author/jimd/">Jim Downard</a></h4><p>Jim Downard is a Spokane native (with a sojourn in Southern California back in the early 1960s) who was raised in a secular family, so says had no personal faith to lose.</p>
<p>	He's always been a history and science buff (getting a bachelor's in the former area at what was then Eastern Washington University in the early 1970s).</p>
</div></div><div class="a-tab-content" id="wpautbox_latest-post"><ul class="wpautbox-post_type-list wpautbox-latest-post"><li><a href="https://spokanefavs.com/icr-on-the-road-and-on-the-ropes/">ICR on the Road &#8230; and on the Ropes</a> <span class="wpautbox-date">- October 16, 2022</span></li><li><a href="https://spokanefavs.com/ask-an-atheist-where-did-human-beings-come-from/">Ask An Atheist: Where did human beings come from?</a> <span class="wpautbox-date">- September 21, 2022</span></li><li><a href="https://spokanefavs.com/ask-an-atheist-reincarnation-and-rebirth/">Ask An Atheist: Reincarnation and Rebirth</a> <span class="wpautbox-date">- July 10, 2022</span></li><li><a href="https://spokanefavs.com/ask-an-atheist-do-you-avoid-holidays/">Ask An Atheist: Do You Avoid Holidays?</a> <span class="wpautbox-date">- January 2, 2022</span></li><li><a href="https://spokanefavs.com/ask-an-atheist-reincarnation-not-god/">Ask An Atheist: Reincarnation, not God</a> <span class="wpautbox-date">- October 8, 2021</span></li><li><a href="https://spokanefavs.com/understanding-prayer-havent-got-a-prayer-or-do-we/">UNDERSTANDING PRAYER: Haven’t got a prayer &#8230; or do we?</a> <span class="wpautbox-date">- July 16, 2021</span></li><li><a href="https://spokanefavs.com/ask-an-atheist-does-it-take-faith-to-be-an-atheist/">Ask An Atheist: Does it Take Faith to be an Atheist?</a> <span class="wpautbox-date">- March 5, 2021</span></li><li><a href="https://spokanefavs.com/ask-an-atheist-a-strictly-negative-position/">Ask An Atheist: A Strictly Negative Position?</a> <span class="wpautbox-date">- July 15, 2020</span></li><li><a href="https://spokanefavs.com/ask-an-atheist-ever-hesitant-to-announce-your-atheism/">Ask an Atheist: Ever hesitant to announce your atheism?</a> <span class="wpautbox-date">- July 7, 2020</span></li><li><a href="https://spokanefavs.com/donald-the-apostate-and-things-to-come/">Donald the Apostate and Things to Come</a> <span class="wpautbox-date">- May 24, 2020</span></li></ul><a href="https://spokanefavs.com/author/jimd/" class="wpautbox-allpost">View All Posts</a></div></div></div>					
									</div><!-- .entry /-->


								<div class="clear"></div>
			</div><!-- .post-inner -->

			<script type="application/ld+json" class="tie-schema-graph">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</script>
		</article><!-- .post-listing -->
		<p class="post-tag">Tags <a href="https://spokanefavs.com/tag/answers-in-genesis/" rel="tag">answers in genesis</a> <a href="https://spokanefavs.com/tag/creation-vs-evolution/" rel="tag">creation vs. evolution</a> <a href="https://spokanefavs.com/tag/institute-of-creation-research/" rel="tag">institute of creation research</a> <a href="https://spokanefavs.com/tag/natural-selection/" rel="tag">natural selection</a> <a href="https://spokanefavs.com/tag/young-earth-creation/" rel="tag">young earth creation</a></p>

		
		

				<div class="post-navigation">
			<div class="post-previous"><a href="https://spokanefavs.com/suicide-prevention-in-black-churches-reclaiming-culture-and-power/" rel="prev"><span>Previous</span> Suicide Prevention in Black Churches: Reclaiming Culture and Power</a></div>
			<div class="post-next"><a href="https://spokanefavs.com/award-winning-indigenous-filmmaker-featured-in-spokane-film-festival-over-weekend/" rel="next"><span>Next</span> Award-winning Indigenous filmmaker featured in Spokane film festival over weekend</a></div>
		</div><!-- .post-navigation -->
		
			<section id="related_posts">
		<div class="block-head">
			<h3>Related Articles</h3><div class="stripe-line"></div>
		</div>
		<div class="post-listing">
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="https://spokanefavs.com/speak-out-refuse-to-justify-the-unthinkable-of-using-limited-nuclear-weaponry/">
						<img width="310" height="165" src="https://spokanefavs.com/wp-content/uploads/2022/10/ps-58-carroll-and-smith-sts-bklyn-hold-a-take-cover-drill-practice-here-youngsters-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" loading="lazy" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="https://spokanefavs.com/speak-out-refuse-to-justify-the-unthinkable-of-using-limited-nuclear-weaponry/" rel="bookmark">Speak out: refuse to justify the &#8216;unthinkable&#8217; of using &#8216;limited&#8217; nuclear weaponry</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>2 days ago</span></p>
			</div>
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="https://spokanefavs.com/marthas-vineyard-the-law-of-refuge-and-jesus/">
						<img width="310" height="165" src="https://spokanefavs.com/wp-content/uploads/2022/10/Marthas-vineyard-pic-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" loading="lazy" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="https://spokanefavs.com/marthas-vineyard-the-law-of-refuge-and-jesus/" rel="bookmark">Martha’s Vineyard, the Law of Refuge, and Jesus</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>3 days ago</span></p>
			</div>
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="https://spokanefavs.com/the-myths-of-christopher-columbuss-legacy-and-who-should-take-his-place/">
						<img width="310" height="165" src="https://spokanefavs.com/wp-content/uploads/2022/10/America-Discovery-Art_welburnstuart-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" loading="lazy" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="https://spokanefavs.com/the-myths-of-christopher-columbuss-legacy-and-who-should-take-his-place/" rel="bookmark">The myths of Christopher Columbus’s legacy and who should take his place</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>5 days ago</span></p>
			</div>
						<div class="clear"></div>
		</div>
	</section>
	
			
	<section id="check-also-box" class="post-listing check-also-right">
		<a href="#" id="check-also-close"><i class="fa fa-close"></i></a>

		<div class="block-head">
			<h3>Check Also</h3>
		</div>

				<div class="check-also-post">
						
			<div class="post-thumbnail">
				<a href="https://spokanefavs.com/a-pothead-confession/">
					<img width="310" height="165" src="https://spokanefavs.com/wp-content/uploads/2022/10/Marijuana_pashabo-e1665503994481-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" loading="lazy" />					<span class="fa overlay-icon"></span>
				</a>
			</div><!-- post-thumbnail /-->
						
			<h2 class="post-title"><a href="https://spokanefavs.com/a-pothead-confession/" rel="bookmark">A Pothead Confession</a></h2>
			<p>From 1965 through 2021, more than 29 million Americans have been arrested for simple marijuana possession, mostly for violating state laws. But thousands were convicted of federal offenses.</p>
		</div>
			</section>
			
			
	
		
				
<div id="comments">


<div class="clear"></div>
	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/icr-on-the-road-and-on-the-ropes/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://spokanefavs.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> <span class="required-field-message" aria-hidden="true">Required fields are marked <span class="required" aria-hidden="true">*</span></span></p><p class="comment-form-comment"><label for="comment">Comment <span class="required" aria-hidden="true">*</span></label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required" aria-hidden="true">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required /></p>
<p class="comment-form-email"><label for="email">Email <span class="required" aria-hidden="true">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='71780' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><input type="hidden" id="ct_checkjs_16a5cdae362b8d27a1d8f8c7b78b4330" name="ct_checkjs" value="0" /></form>	</div><!-- #respond -->
	

</div><!-- #comments -->

	</div><!-- .content -->
<aside id="sidebar">
	<div class="theiaStickySidebar">
<div id="block-7" class="widget widget_block widget_media_image"><div class="widget-container">
<figure class="wp-block-image size-full"><a href="https://spokanefavs.com/favs-is-reading-launches-sign-up-for-fall-2022-book-club/"><img loading="lazy" width="300" height="250" src="https://spokanefavs.com/wp-content/uploads/2022/10/0.png" alt="" class="wp-image-71495"/></a></figure>
</div></div><!-- .widget /--><div id="block-9" class="widget widget_block"><div class="widget-container"><p><!-- Begin Give Lively Fundraising Widget --><br>
<script>gl=document.createElement('script');gl.src='https://secure.givelively.org/widgets/branded_donation/spokane-favs.js';document.getElementsByTagName('head')[0].appendChild(gl);</script></p>
<div data-widget-src="https://secure.givelively.org/donate/spokane-favs?ref=sd_widget" id="give-lively-widget" class="gl-branded-donation-widget"></div>
<p><!-- End Give Lively Fundraising Widget --></p></div></div><!-- .widget /--><div id="ads300_250-widget-2" class="widget e3lan e3lan300_250-widget"><div class="widget-top"><h4>Our Sponsors</h4><div class="stripe-line"></div></div>
						<div class="widget-container">		<div  class="e3lan-widget-content e3lan300-250">
							</div>
	</div></div><!-- .widget /--><div id="block-5" class="widget widget_block widget_media_image"><div class="widget-container">
<figure class="wp-block-image size-full"><a href="https://stgertrudes.org/"><img loading="lazy" width="300" height="250" src="https://spokanefavs.com/wp-content/uploads/2022/02/0-1.jpg" alt="" class="wp-image-67210"/></a></figure>
</div></div><!-- .widget /--><div id="media_image-40" class="widget widget_media_image"><div class="widget-top"><h4> </h4><div class="stripe-line"></div></div>
						<div class="widget-container"><a href="http://www.holytrinityspokane.org/"><img width="300" height="250" src="https://spokanefavs.com/wp-content/uploads/2019/11/orthodoxad2.png" class="image wp-image-60481  attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" /></a></div></div><!-- .widget /--><div id="custom_html-4" class="widget_text widget widget_custom_html"><div class="widget-top"><h4> </h4><div class="stripe-line"></div></div>
						<div class="widget-container"><div class="textwidget custom-html-widget"><div id="RecentComments" class="dsq-widget">
 <h2>Recent Comments</h2>
 <script type="text/javascript" src="https://spokanefavs.disqus.com/recent_comments_widget.js?num_items=5&hide_mods=0&hide_avatars=0&avatar_size=32&excerpt_length=100"></script>
</div></div></div></div><!-- .widget /--><div id="media_image-61" class="widget widget_media_image"><div class="widget-top"><h4> </h4><div class="stripe-line"></div></div>
						<div class="widget-container"><a href="https://smile.amazon.com/ref=smi_ext_ch_47-4309024_dl?_encoding=UTF8&#038;ein=47-4309024&#038;ref_=smi_chpf_redirect&#038;ref_=smi_ext_ch_47-4309024_cl"><img width="300" height="251" src="https://spokanefavs.com/wp-content/uploads/2020/09/amazonsmile.png" class="image wp-image-63063  attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" /></a></div></div><!-- .widget /-->	</div><!-- .theiaStickySidebar /-->
</aside><!-- #sidebar /-->	<div class="clear"></div>
</div><!-- .container /-->

<footer id="theme-footer">
	<div id="footer-widget-area" class="footer-3c">

	
	

	
		
	</div><!-- #footer-widget-area -->
	<div class="clear"></div>
</footer><!-- .Footer /-->
				
<div class="clear"></div>
<div class="footer-bottom">
	<div class="container">
		<div class="alignright">
			Powered by <a href="http://wordpress.org">WordPress</a> | Designed by <a href="http://tielabs.com/">TieLabs</a>		</div>
				<div class="social-icons">
		<a class="ttip-none" title="Rss" href="https://spokanefavs.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="https://www.facebook.com/SpokaneFAVS/" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="https://twitter.com/spokanefavs" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/spokanefavs/" target="_blank"><i class="fa fa-instagram"></i></a>
			</div>

		
		<div class="alignleft">
			© Copyright 2022, All Rights Reserved		</div>
		<div class="clear"></div>
	</div><!-- .Container -->
</div><!-- .Footer bottom -->

</div><!-- .inner-Wrapper -->
</div><!-- #Wrapper -->
</div><!-- .Wrapper-outer -->
	<div id="topcontrol" class="fa fa-angle-up" title="Scroll To Top"></div>
<div id="fb-root"></div>
<img alt="Cleantalk Pixel" id="apbct_pixel" style="display: none;" src="https://moderate9.cleantalk.org/pixel/5cc1f75bcadb777344f27d950b420a33.gif"><script>				
                    window.addEventListener('DOMContentLoaded', function () {
                        setTimeout(function(){
                            if( document.querySelectorAll('[name^=ct_checkjs]').length > 0 ) {
                                apbct_public_sendREST(
                                    'js_keys__get',
                                    { callback: apbct_js_keys__set_input_value }
                                )
                            }
                        },0)					    
                    })				
                </script>		<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		    <!-- Meta Pixel Event Code -->
    <script type='text/javascript'>
        document.addEventListener( 'wpcf7mailsent', function( event ) {
        if( "fb_pxl_code" in event.detail.apiResponse){
          eval(event.detail.apiResponse.fb_pxl_code);
        }
      }, false );
    </script>
    <!-- End Meta Pixel Event Code -->
    <div id='fb-pxl-ajax-code'></div><script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script><script type='text/javascript' id='stripe-handler-ng-js-extra'>
/* <![CDATA[ */
var wpASPNG = {"iframeUrl":"https:\/\/spokanefavs.com\/asp-payment-box\/","ppSlug":"asp-payment-box","prefetch":"","ckey":"2fb8b914dd0b99d08e64de8aec7c692d","aspDevMode":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://spokanefavs.com/wp-content/plugins/stripe-payments/public/assets/js/stripe-handler-ng.js' id='stripe-handler-ng-js'></script>
<script type='text/javascript' src='https://spokanefavs.com/wp-content/plugins/wp-author-box-pro/lib/js/jquery.a-tab.js' id='jquery-wpautbox-tab-js'></script>
<script type='text/javascript' id='jquery-wpautbox-pro-js-extra'>
/* <![CDATA[ */
var wpautboxAjax = {"ajaxurl":"https:\/\/spokanefavs.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://spokanefavs.com/wp-content/plugins/wp-author-box-pro/lib/js/jquery.wpautbox.js' id='jquery-wpautbox-pro-js'></script>
<script type='text/javascript' id='tie-scripts-js-extra'>
/* <![CDATA[ */
var tie = {"mobile_menu_active":"true","mobile_menu_top":"","lightbox_all":"true","lightbox_gallery":"true","woocommerce_lightbox":"","lightbox_skin":"dark","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"","is_singular":"1","reading_indicator":"","lang_no_results":"No Results","lang_results_found":"Results Found"};
/* ]]> */
</script>
<script type='text/javascript' src='https://spokanefavs.com/wp-content/themes/sahifa/js/tie-scripts.js' id='tie-scripts-js'></script>
<script type='text/javascript' src='https://spokanefavs.com/wp-content/themes/sahifa/js/ilightbox.packed.js' id='tie-ilightbox-js'></script>
<script type='text/javascript' id='heateor_sssp_sharing_js-js-before'>
function heateorSsspLoadEvent(e) {var t=window.onload;if (typeof window.onload!= "function") {window.onload=e} else {window.onload=function() {t();e()}}};var heateorSsspSaveShareCount = 1;var heateorSsspInstagramUsername= "",heateorSsspYoutubeUsername= "", heateorSsspSharingAjaxUrl = 'https://spokanefavs.com/wp-admin/admin-ajax.php', heateorSsspCloseIconPath = 'https://spokanefavs.com/wp-content/plugins/sassy-social-share-premium/public/../images/close.png', heateorSsspPluginIconPath = 'https://spokanefavs.com/wp-content/plugins/sassy-social-share-premium/public/../images/logo.png', heateorSsspHorizontalSharingCountEnable = 1, heateorSsspVerticalSharingCountEnable = 0, heateorSsspSharingOffset = -10; var heateorSsspMobileStickySharingEnabled = 0;var heateorSsspCopyLinkMessage = "Link copied.";var heateorSsspUrlCountFetched = [], heateorSsspSharesText = 'Shares', heateorSsspShareText = 'Share';function heateorSsspPopup(e) {window.open(e,"popUpWindow","height=400,width=600,left=400,top=100,resizable,scrollbars,toolbar=0,personalbar=0,menubar=no,location=no,directories=no,status")};var heateorSsspWhatsappShareAPI = "web"; var heateorSsmiAjaxUrl = "https://spokanefavs.com/wp-admin/admin-ajax.php";window.dataLayer = window.dataLayer || [];function gtag() {dataLayer.push(arguments);}gtag( 'js', new Date() );gtag( 'config', '85992401' );jQuery(document) .on( 'click', ' .heateor_sssp_sharing_container li a', function() {var title = jQuery(this) .attr( 'alt' );if ( title != 'Total Shares' ) {if ( title == 'More' ) {jQuery( '#heateor_sssp_sharing_more_content a' ) .click(function() {heateorSsspSsgaSocialEventsTracking(jQuery(this) .attr( 'title' ), location.href);});} else {heateorSsspSsgaSocialEventsTracking(title, location.href);}}});function heateorSsspSsgaSocialPluginsTracking(socialNetwork, action, url) {gtag( 'event', action, {'event_category': 'Heateor Social Share', 'event_label': socialNetwork, content_id:url});}function heateorSsspSsgaSocialEventsTracking(socialNetwork, url) {gtag( 'event', 'Social Share', {'event_category': 'Heateor Social Share', 'event_label': socialNetwork, content_id:url});}
</script>
<script type='text/javascript' src='https://spokanefavs.com/wp-content/plugins/sassy-social-share-premium/public/js/sassy-social-share-premium-public.js' id='heateor_sssp_sharing_js-js'></script>
<script type='text/javascript' src='https://spokanefavs.com/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' src='https://spokanefavs.com/wp-content/themes/sahifa/js/search.js' id='tie-search-js'></script>
</body>
</html>