<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://spokanefavs.com/xmlrpc.php" />
<meta property="og:title" content="Everyday Is Mother&#8217;s Day: A Jewish Perspective - SpokaneFāVS"/>
<meta property="og:type" content="article"/>
<meta property="og:description" content="Everyday Is Mother's Day: A Jewish Perspective By Hyphen Parent I once read the declaration that eve"/>
<meta property="og:url" content="https://spokanefavs.com/everyday-is-mothers-day-a-jewish-perspective/"/>
<meta property="og:site_name" content="SpokaneFāVS"/>
<meta property="og:image" content="https://spokanefavs.com/wp-content/uploads/2021/05/mothersday_dp.jpg" />
<style type="text/css">			.heateorSssInstagramBackground{background:radial-gradient(circle at 30% 107%,#fdf497 0,#fdf497 5%,#fd5949 45%,#d6249f 60%,#285aeb 90%)}
											.heateor_sss_horizontal_sharing .heateorSssSharing,.heateor_sss_standard_follow_icons_container .heateorSssSharing{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
				.heateor_sss_horizontal_sharing .heateorSssTCBackground{
			color:#666;
		}
				.heateor_sss_horizontal_sharing .heateorSssSharing:hover,.heateor_sss_standard_follow_icons_container .heateorSssSharing:hover{
						border-color: transparent;
		}
		.heateor_sss_vertical_sharing .heateorSssSharing,.heateor_sss_floating_follow_icons_container .heateorSssSharing{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
				.heateor_sss_vertical_sharing .heateorSssTCBackground{
			color:#666;
		}
				.heateor_sss_vertical_sharing .heateorSssSharing:hover,.heateor_sss_floating_follow_icons_container .heateorSssSharing:hover{
						border-color: transparent;
		}
		
						div.heateor_sss_horizontal_sharing .heateor_sss_square_count{display: block}
								div.heateor_sss_vertical_sharing .heateor_sss_square_count{display: block}
				@media screen and (max-width:783px) {.heateor_sss_vertical_sharing{display:none!important}}@media screen and (max-width:783px) {.heateor_sss_floating_follow_icons_container{display:none!important}}</style><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO Premium plugin v16.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Everyday Is Mother&#039;s Day: A Jewish Perspective - SpokaneFāVS</title>
	<meta name="description" content="I once read the declaration that every day is Mother’s Day and Father’s Day in Judaism because of the command to honor one’s parents. This, however, is an oversimplification." />
	<link rel="canonical" href="https://spokanefavs.com/everyday-is-mothers-day-a-jewish-perspective/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Everyday Is Mother&#039;s Day: A Jewish Perspective - SpokaneFāVS" />
	<meta property="og:description" content="I once read the declaration that every day is Mother’s Day and Father’s Day in Judaism because of the command to honor one’s parents. This, however, is an oversimplification." />
	<meta property="og:url" content="https://spokanefavs.com/everyday-is-mothers-day-a-jewish-perspective/" />
	<meta property="og:site_name" content="SpokaneFāVS" />
	<meta property="article:publisher" content="http://www.facebook.com/SpokaneFAVS" />
	<meta property="article:published_time" content="2021-05-09T15:41:35+00:00" />
	<meta property="article:modified_time" content="2021-05-09T15:41:37+00:00" />
	<meta property="og:image" content="https://spokanefavs.com/wp-content/uploads/2021/05/mothersday_dp.jpg" />
	<meta property="og:image:width" content="650" />
	<meta property="og:image:height" content="434" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@spokanefavs" />
	<meta name="twitter:site" content="@spokanefavs" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Hyphen Parent">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="6 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://spokanefavs.com/#organization","name":"SpokaneFAVS","url":"https://spokanefavs.com/","sameAs":["http://www.facebook.com/SpokaneFAVS","https://instagram.com/spokanefavs/","https://www.linkedin.com/pub/tracy-simmons/7/286/70b","https://www.youtube.com/channel/UCd6_3BaaIhGz4GB6YmsPSDQ","https://www.pinterest.com/spokanefavs/","https://twitter.com/spokanefavs"],"logo":{"@type":"ImageObject","@id":"https://spokanefavs.com/#logo","inLanguage":"en-US","url":"https://spokanefavs.com/wp-content/uploads/2019/04/Spokane-FAVS_logo-e1561920544853.png","contentUrl":"https://spokanefavs.com/wp-content/uploads/2019/04/Spokane-FAVS_logo-e1561920544853.png","width":190,"height":121,"caption":"SpokaneFAVS"},"image":{"@id":"https://spokanefavs.com/#logo"}},{"@type":"WebSite","@id":"https://spokanefavs.com/#website","url":"https://spokanefavs.com/","name":"SpokaneF\u0101VS","description":"","publisher":{"@id":"https://spokanefavs.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://spokanefavs.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://spokanefavs.com/everyday-is-mothers-day-a-jewish-perspective/#primaryimage","inLanguage":"en-US","url":"https://spokanefavs.com/wp-content/uploads/2021/05/mothersday_dp.jpg","contentUrl":"https://spokanefavs.com/wp-content/uploads/2021/05/mothersday_dp.jpg","width":650,"height":434,"caption":"mother and son at sunset/DepositPhoto"},{"@type":"WebPage","@id":"https://spokanefavs.com/everyday-is-mothers-day-a-jewish-perspective/#webpage","url":"https://spokanefavs.com/everyday-is-mothers-day-a-jewish-perspective/","name":"Everyday Is Mother's Day: A Jewish Perspective - SpokaneF\u0101VS","isPartOf":{"@id":"https://spokanefavs.com/#website"},"primaryImageOfPage":{"@id":"https://spokanefavs.com/everyday-is-mothers-day-a-jewish-perspective/#primaryimage"},"datePublished":"2021-05-09T15:41:35+00:00","dateModified":"2021-05-09T15:41:37+00:00","description":"I once read the declaration that every day is Mother\u2019s Day and Father\u2019s Day in Judaism because of the command to honor one\u2019s parents. This, however, is an oversimplification.","breadcrumb":{"@id":"https://spokanefavs.com/everyday-is-mothers-day-a-jewish-perspective/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://spokanefavs.com/everyday-is-mothers-day-a-jewish-perspective/"]}]},{"@type":"BreadcrumbList","@id":"https://spokanefavs.com/everyday-is-mothers-day-a-jewish-perspective/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://spokanefavs.com/","url":"https://spokanefavs.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https://spokanefavs.com/everyday-is-mothers-day-a-jewish-perspective/#webpage"}}]},{"@type":"Article","@id":"https://spokanefavs.com/everyday-is-mothers-day-a-jewish-perspective/#article","isPartOf":{"@id":"https://spokanefavs.com/everyday-is-mothers-day-a-jewish-perspective/#webpage"},"author":{"@id":"https://spokanefavs.com/#/schema/person/d9c846d98ca4d480caa0aeb53cb76464"},"headline":"Everyday Is Mother&#8217;s Day: A Jewish Perspective","datePublished":"2021-05-09T15:41:35+00:00","dateModified":"2021-05-09T15:41:37+00:00","mainEntityOfPage":{"@id":"https://spokanefavs.com/everyday-is-mothers-day-a-jewish-perspective/#webpage"},"commentCount":0,"publisher":{"@id":"https://spokanefavs.com/#organization"},"image":{"@id":"https://spokanefavs.com/everyday-is-mothers-day-a-jewish-perspective/#primaryimage"},"keywords":["father&#039;s day judaism","honor they father and mother","honor thy parents","judaism","mother's day","mother&#039;s day judaism"],"articleSection":["Commentary"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://spokanefavs.com/everyday-is-mothers-day-a-jewish-perspective/#respond"]}]},{"@type":"Person","@id":"https://spokanefavs.com/#/schema/person/d9c846d98ca4d480caa0aeb53cb76464","name":"Hyphen Parent","image":{"@type":"ImageObject","@id":"https://spokanefavs.com/#personlogo","inLanguage":"en-US","url":"http://spokanefavs.com/wp-content/uploads/2014/08/HyphenHuffmanparent-96x96.jpeg","contentUrl":"http://spokanefavs.com/wp-content/uploads/2014/08/HyphenHuffmanparent-96x96.jpeg","caption":"Hyphen Parent"},"description":"Dorothy-Ann Parent (better known as Hyphen) is a writer, a traditional Jew, a seeker of justice, a lover of stories, the self-proclaimed Jewish Molly Weasley, hobbit-sized, and best not left unattended in a bookshop or animal shelter."}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="SpokaneFāVS &raquo; Feed" href="https://spokanefavs.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="SpokaneFāVS &raquo; Comments Feed" href="https://spokanefavs.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="SpokaneFāVS &raquo; iCal Feed" href="https://spokanefavs.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="SpokaneFāVS &raquo; Everyday Is Mother&#8217;s Day: A Jewish Perspective Comments Feed" href="https://spokanefavs.com/everyday-is-mothers-day-a-jewish-perspective/feed/" />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v7.17.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-50929201-1"  type="text/javascript" data-cfasync="false"></script>
			<script type="text/javascript" data-cfasync="false">
				var mi_version = '7.17.0';
				var mi_track_user = true;
				var mi_no_track_reason = '';
				
								var disableStr = 'ga-disable-UA-50929201-1';

				/* Function to detect opted out users */
				function __gtagTrackerIsOptedOut() {
					return document.cookie.indexOf( disableStr + '=true' ) > - 1;
				}

				/* Disable tracking if the opt-out cookie exists. */
				if ( __gtagTrackerIsOptedOut() ) {
					window[disableStr] = true;
				}

				/* Opt-out function */
				function __gtagTrackerOptout() {
					document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
					window[disableStr] = true;
				}

				if ( 'undefined' === typeof gaOptout ) {
					function gaOptout() {
						__gtagTrackerOptout();
					}
				}
								window.dataLayer = window.dataLayer || [];
				if ( mi_track_user ) {
					function __gtagTracker() {dataLayer.push( arguments );}
					__gtagTracker( 'js', new Date() );
					__gtagTracker( 'set', {
						'developer_id.dZGIzZG' : true,
						                    });
					__gtagTracker( 'config', 'UA-50929201-1', {
						forceSSL:true,					} );
										window.gtag = __gtagTracker;										(
						function () {
							/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
							/* ga and __gaTracker compatibility shim. */
							var noopfn = function () {
								return null;
							};
							var newtracker = function () {
								return new Tracker();
							};
							var Tracker = function () {
								return null;
							};
							var p = Tracker.prototype;
							p.get = noopfn;
							p.set = noopfn;
							p.send = function (){
								var args = Array.prototype.slice.call(arguments);
								args.unshift( 'send' );
								__gaTracker.apply(null, args);
							};
							var __gaTracker = function () {
								var len = arguments.length;
								if ( len === 0 ) {
									return;
								}
								var f = arguments[len - 1];
								if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
									if ( 'send' === arguments[0] ) {
										var hitConverted, hitObject = false, action;
										if ( 'event' === arguments[1] ) {
											if ( 'undefined' !== typeof arguments[3] ) {
												hitObject = {
													'eventAction': arguments[3],
													'eventCategory': arguments[2],
													'eventLabel': arguments[4],
													'value': arguments[5] ? arguments[5] : 1,
												}
											}
										}
										if ( typeof arguments[2] === 'object' ) {
											hitObject = arguments[2];
										}
										if ( typeof arguments[5] === 'object' ) {
											Object.assign( hitObject, arguments[5] );
										}
										if ( 'undefined' !== typeof (
											arguments[1].hitType
										) ) {
											hitObject = arguments[1];
										}
										if ( hitObject ) {
											action = 'timing' === arguments[1].hitType ? 'timing_complete' : hitObject.eventAction;
											hitConverted = mapArgs( hitObject );
											__gtagTracker( 'event', action, hitConverted );
										}
									}
									return;
								}

								function mapArgs( args ) {
									var gaKey, hit = {};
									var gaMap = {
										'eventCategory': 'event_category',
										'eventAction': 'event_action',
										'eventLabel': 'event_label',
										'eventValue': 'event_value',
										'nonInteraction': 'non_interaction',
										'timingCategory': 'event_category',
										'timingVar': 'name',
										'timingValue': 'value',
										'timingLabel': 'event_label',
									};
									for ( gaKey in gaMap ) {
										if ( 'undefined' !== typeof args[gaKey] ) {
											hit[gaMap[gaKey]] = args[gaKey];
										}
									}
									return hit;
								}

								try {
									f.hitCallback();
								} catch ( ex ) {
								}
							};
							__gaTracker.create = newtracker;
							__gaTracker.getByName = newtracker;
							__gaTracker.getAll = function () {
								return [];
							};
							__gaTracker.remove = noopfn;
							__gaTracker.loaded = true;
							window['__gaTracker'] = __gaTracker;
						}
					)();
									} else {
										console.log( "" );
					( function () {
							function __gtagTracker() {
								return null;
							}
							window['__gtagTracker'] = __gtagTracker;
							window['gtag'] = __gtagTracker;
					} )();
									}
			</script>
				<!-- / Google Analytics by MonsterInsights -->
				<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/spokanefavs.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='tribe-common-skeleton-style-css'  href='https://spokanefavs.com/wp-content/plugins/the-events-calendar/common/src/resources/css/common-skeleton.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-tooltip-css'  href='https://spokanefavs.com/wp-content/plugins/the-events-calendar/common/src/resources/css/tooltip.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://spokanefavs.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='dntplgn_style-css'  href='https://spokanefavs.com/wp-content/plugins/recurring-donation/css/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='jquery_ui_style-css'  href='https://spokanefavs.com/wp-content/plugins/recurring-donation/css/jquery-ui-styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='stripe-handler-ng-style-css'  href='https://spokanefavs.com/wp-content/plugins/stripe-payments/public/assets/css/public.css' type='text/css' media='all' />
<link rel='stylesheet' id='css-wpautbox-tab-css'  href='https://spokanefavs.com/wp-content/plugins/wp-author-box-pro/lib/css/jquery-a-tabs.css' type='text/css' media='all' />
<link rel='stylesheet' id='css-wpautbox-css'  href='https://spokanefavs.com/wp-content/plugins/wp-author-box-pro/lib/css/wpautbox.css' type='text/css' media='all' />
<link rel='stylesheet' id='css-wpautbox-aqua-css'  href='https://spokanefavs.com/wp-content/plugins/wp-author-box-pro/lib/css/aqua.css' type='text/css' media='all' />
<link rel='stylesheet' id='wpautbox-elusive-icon-css'  href='https://spokanefavs.com/wp-content/plugins/wp-author-box-pro/includes/ReduxFramework/ReduxCore/assets/css/vendor/elusive-icons/elusive-icons.css' type='text/css' media='all' />
<link rel='stylesheet' id='yop-public-css'  href='https://spokanefavs.com/wp-content/plugins/yop-poll/public/assets/css/yop-poll-public-6.2.7.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-style-css'  href='https://spokanefavs.com/wp-content/themes/sahifa/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-ilightbox-skin-css'  href='https://spokanefavs.com/wp-content/themes/sahifa/css/ilightbox/dark-skin/skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='Droid+Sans-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media='all' />
<link rel='stylesheet' id='heateor_sss_frontend_css-css'  href='https://spokanefavs.com/wp-content/plugins/sassy-social-share/public/css/sassy-social-share-public.css' type='text/css' media='all' />
<link rel='stylesheet' id='heateor_sss_sharing_default_svg-css'  href='https://spokanefavs.com/wp-content/plugins/sassy-social-share/admin/css/sassy-social-share-svg.css' type='text/css' media='all' />
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/spokanefavs.com","hash_tracking":"false","ua":"UA-50929201-1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://spokanefavs.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend-gtag.js' id='monsterinsights-frontend-script-js'></script>
<script type='text/javascript' src='https://spokanefavs.com/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://spokanefavs.com/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://spokanefavs.com/wp-includes/js/jquery/ui/core.min.js' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://spokanefavs.com/wp-includes/js/jquery/ui/tabs.min.js' id='jquery-ui-tabs-js'></script>
<script type='text/javascript' src='https://spokanefavs.com/wp-content/plugins/recurring-donation/js/script.js' id='dntplgn_script-js'></script>
<script type='text/javascript' id='yop-public-js-extra'>
/* <![CDATA[ */
var objectL10n = {"yopPollParams":{"urlParams":{"ajax":"https:\/\/spokanefavs.com\/wp-admin\/admin-ajax.php","wpLogin":"https:\/\/spokanefavs.com\/wp-login.php?redirect_to=https%3A%2F%2Fspokanefavs.com%2Fwp-admin%2Fadmin-ajax.php%3Faction%3Dyop_poll_record_wordpress_vote"},"apiParams":{"reCaptcha":{"siteKey":""},"reCaptchaV2Invisible":{"siteKey":""},"reCaptchaV3":{"siteKey":""}},"captchaParams":{"imgPath":"https:\/\/spokanefavs.com\/wp-content\/plugins\/yop-poll\/public\/assets\/img\/","url":"https:\/\/spokanefavs.com\/wp-content\/plugins\/yop-poll\/app.php","accessibilityAlt":"Sound icon","accessibilityTitle":"Accessibility option: listen to a question and answer it!","accessibilityDescription":"Type below the <strong>answer<\/strong> to what you hear. Numbers or words:","explanation":"Click or touch the <strong>ANSWER<\/strong>","refreshAlt":"Refresh\/reload icon","refreshTitle":"Refresh\/reload: get new images and accessibility option!"},"voteParams":{"invalidPoll":"Invalid Poll","noAnswersSelected":"No answer selected","minAnswersRequired":"At least {min_answers_allowed} answer(s) required","maxAnswersRequired":"A max of {max_answers_allowed} answer(s) accepted","noAnswerForOther":"No other answer entered","noValueForCustomField":"{custom_field_name} is required","consentNotChecked":"You must agree to our terms and conditions","noCaptchaSelected":"Captcha is required","thankYou":"Thank you for your vote"},"resultsParams":{"singleVote":"vote","multipleVotes":"votes","singleAnswer":"answer","multipleAnswers":"answers"}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://spokanefavs.com/wp-content/plugins/yop-poll/public/assets/js/yop-poll-public-6.2.7.min.js' id='yop-public-js'></script>
<link rel="https://api.w.org/" href="https://spokanefavs.com/wp-json/" /><link rel="alternate" type="application/json" href="https://spokanefavs.com/wp-json/wp/v2/posts/64968" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://spokanefavs.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://spokanefavs.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.1" />
<link rel='shortlink' href='https://spokanefavs.com/?p=64968' />
<link rel="alternate" type="application/json+oembed" href="https://spokanefavs.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fspokanefavs.com%2Feveryday-is-mothers-day-a-jewish-perspective%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://spokanefavs.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fspokanefavs.com%2Feveryday-is-mothers-day-a-jewish-perspective%2F&#038;format=xml" />
<script type="text/javascript">
  window.MemberfulOptions = {
    site: "https://spokanefavs.memberful.com",
    intercept: [
            "http://spokanefavs.com/?memberful_endpoint=auth",
            "https://spokanefavs.com/?memberful_endpoint=auth",
            "http://spokanefavs.com?memberful_endpoint=auth",
            "https://spokanefavs.com?memberful_endpoint=auth",
          ],
    memberSignedIn: false  };

  (function() {
    var s = document.createElement('script');
    s.type = 'text/javascript';
    s.async = true;
    s.src = 'https://d35xxde4fgg0cx.cloudfront.net/assets/embedded.js';

    setup = function() { window.MemberfulEmbedded.setup(); };

    s.addEventListener("load", setup, false);

    ( document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0] ).appendChild( s );
  })();
</script>
<style type="text/css">.a-tabs .wpautbox-socials-custom a .wpautbox-icon{ color: #fff;}.a-tabs .wpautbox-socials-custom a:hover .wpautbox-icon{ color: #fff;}.a-tabs .wpautbox-socials-custom a .wpautbox-icon{ background: #333;}.a-tabs .wpautbox-socials-custom a:hover .wpautbox-icon{ background: #222;}.entry-title{
    display:none !important;
}</style><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://spokanefavs.com"><link rel="https://theeventscalendar.com/" href="https://spokanefavs.com/wp-json/tribe/events/v1/" /><link rel="shortcut icon" href="https://spokanefavs.com/wp-content/uploads/2014/08/favicon1.jpg" title="Favicon" />
<!--[if IE]>
<script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script>
<![endif]-->
<!--[if lt IE 9]>
<script src="https://spokanefavs.com/wp-content/themes/sahifa/js/html5.js"></script>
<script src="https://spokanefavs.com/wp-content/themes/sahifa/js/selectivizr-min.js"></script>
<![endif]-->
<!--[if IE 9]>
<link rel="stylesheet" type="text/css" media="all" href="https://spokanefavs.com/wp-content/themes/sahifa/css/ie9.css" />
<![endif]-->
<!--[if IE 8]>
<link rel="stylesheet" type="text/css" media="all" href="https://spokanefavs.com/wp-content/themes/sahifa/css/ie8.css" />
<![endif]-->
<!--[if IE 7]>
<link rel="stylesheet" type="text/css" media="all" href="https://spokanefavs.com/wp-content/themes/sahifa/css/ie7.css" />
<![endif]-->


<meta name="viewport" content="width=device-width, initial-scale=1.0" />

<script data-ad-client="ca-pub-7470048322015446" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script type="text/javascript" src="//downloads.mailchimp.com/js/signup-forms/popup/unique-methods/embed.js" data-dojo-config="usePlainJson: true, isDebug: false"></script><script type="text/javascript">window.dojoRequire(["mojo/signup-forms/Loader"], function(L) { L.start({"baseUrl":"mc.us4.list-manage.com","uuid":"e2f586d254446282b7baca281","lid":"ccfb1c769e","uniqueMethods":true}) })</script>


<style type="text/css" media="screen">

body{
	font-family: 'Droid Sans';
}

.page-title{
	font-family: Impact, Charcoal, sans-serif;
	font-size : 30px;
	font-weight: bold;
}

.post-title{
	font-size : 40px;
}

#main-nav,
.cat-box-content,
#sidebar .widget-container,
.post-listing,
#commentform {
	border-bottom-color: #37b8eb;
}

.search-block .search-button,
#topcontrol,
#main-nav ul li.current-menu-item a,
#main-nav ul li.current-menu-item a:hover,
#main-nav ul li.current_page_parent a,
#main-nav ul li.current_page_parent a:hover,
#main-nav ul li.current-menu-parent a,
#main-nav ul li.current-menu-parent a:hover,
#main-nav ul li.current-page-ancestor a,
#main-nav ul li.current-page-ancestor a:hover,
.pagination span.current,
.share-post span.share-text,
.flex-control-paging li a.flex-active,
.ei-slider-thumbs li.ei-slider-element,
.review-percentage .review-item span span,
.review-final-score,
.button,
a.button,
a.more-link,
#main-content input[type="submit"],
.form-submit #submit,
#login-form .login-button,
.widget-feedburner .feedburner-subscribe,
input[type="submit"],
#buddypress button,
#buddypress a.button,
#buddypress input[type=submit],
#buddypress input[type=reset],
#buddypress ul.button-nav li a,
#buddypress div.generic-button a,
#buddypress .comment-reply-link,
#buddypress div.item-list-tabs ul li a span,
#buddypress div.item-list-tabs ul li.selected a,
#buddypress div.item-list-tabs ul li.current a,
#buddypress #members-directory-form div.item-list-tabs ul li.selected span,
#members-list-options a.selected,
#groups-list-options a.selected,
body.dark-skin #buddypress div.item-list-tabs ul li a span,
body.dark-skin #buddypress div.item-list-tabs ul li.selected a,
body.dark-skin #buddypress div.item-list-tabs ul li.current a,
body.dark-skin #members-list-options a.selected,
body.dark-skin #groups-list-options a.selected,
.search-block-large .search-button,
#featured-posts .flex-next:hover,
#featured-posts .flex-prev:hover,
a.tie-cart span.shooping-count,
.woocommerce span.onsale,
.woocommerce-page span.onsale ,
.woocommerce .widget_price_filter .ui-slider .ui-slider-handle,
.woocommerce-page .widget_price_filter .ui-slider .ui-slider-handle,
#check-also-close,
a.post-slideshow-next,
a.post-slideshow-prev,
.widget_price_filter .ui-slider .ui-slider-handle,
.quantity .minus:hover,
.quantity .plus:hover,
.mejs-container .mejs-controls .mejs-time-rail .mejs-time-current,
#reading-position-indicator  {
	background-color:#37b8eb;
}

::-webkit-scrollbar-thumb{
	background-color:#37b8eb !important;
}

#theme-footer,
#theme-header,
.top-nav ul li.current-menu-item:before,
#main-nav .menu-sub-content ,
#main-nav ul ul,
#check-also-box {
	border-top-color: #37b8eb;
}

.search-block:after {
	border-right-color:#37b8eb;
}

body.rtl .search-block:after {
	border-left-color:#37b8eb;
}

#main-nav ul > li.menu-item-has-children:hover > a:after,
#main-nav ul > li.mega-menu:hover > a:after {
	border-color:transparent transparent #37b8eb;
}

.widget.timeline-posts li a:hover,
.widget.timeline-posts li a:hover span.tie-date {
	color: #37b8eb;
}

.widget.timeline-posts li a:hover span.tie-date:before {
	background: #37b8eb;
	border-color: #37b8eb;
}

#order_review,
#order_review_heading {
	border-color: #37b8eb;
}


body {
	background-image : url(https://spokanefavs.com/wp-content/themes/sahifa/images/patterns/body-bg3.png);
	background-position: top center;
}

a {
	color: #259ce6;
}
		
</style>

		<script type="text/javascript">
			/* <![CDATA[ */
				var sf_position = '0';
				var sf_templates = "<a href=\"{search_url_escaped}\">View All Results<\/a>";
				var sf_input = '.search-live';
				jQuery(document).ready(function(){
					jQuery(sf_input).ajaxyLiveSearch({"expand":false,"searchUrl":"https:\/\/spokanefavs.com\/?s=%s","text":"Search","delay":500,"iwidth":180,"width":315,"ajaxUrl":"https:\/\/spokanefavs.com\/wp-admin\/admin-ajax.php","rtl":0});
					jQuery(".live-search_ajaxy-selective-input").keyup(function() {
						var width = jQuery(this).val().length * 8;
						if(width < 50) {
							width = 50;
						}
						jQuery(this).width(width);
					});
					jQuery(".live-search_ajaxy-selective-search").click(function() {
						jQuery(this).find(".live-search_ajaxy-selective-input").focus();
					});
					jQuery(".live-search_ajaxy-selective-close").click(function() {
						jQuery(this).parent().remove();
					});
				});
			/* ]]> */
		</script>
		<link rel="icon" href="https://spokanefavs.com/wp-content/uploads/2019/06/cropped-Spokane-FAVS_logo-copy-e1561920891212-32x32.png" sizes="32x32" />
<link rel="icon" href="https://spokanefavs.com/wp-content/uploads/2019/06/cropped-Spokane-FAVS_logo-copy-e1561920891212-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://spokanefavs.com/wp-content/uploads/2019/06/cropped-Spokane-FAVS_logo-copy-e1561920891212-180x180.png" />
<meta name="msapplication-TileImage" content="https://spokanefavs.com/wp-content/uploads/2019/06/cropped-Spokane-FAVS_logo-copy-e1561920891212-270x270.png" />
</head>
<body id="top" class="post-template-default single single-post postid-64968 single-format-standard tribe-no-js tribe-theme-sahifa lazy-enabled">

<div class="wrapper-outer">

	<div class="background-cover"></div>

	<aside id="slide-out">

			<div class="search-mobile">
			<form method="get" id="searchform-mobile" action="https://spokanefavs.com/">
				<button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button>
				<input type="text" id="s-mobile" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  />
			</form>
		</div><!-- .search-mobile /-->
	
			<div class="social-icons">
		<a class="ttip-none" title="Rss" href="https://spokanefavs.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="https://www.facebook.com/SpokaneFAVS/" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="https://twitter.com/spokanefavs" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/spokanefavs/" target="_blank"><i class="fa fa-instagram"></i></a>
			</div>

	
		<div id="mobile-menu" ></div>
	</aside><!-- #slide-out /-->

		<div id="wrapper" class="boxed">
		<div class="inner-wrapper">

		<header id="theme-header" class="theme-header">
						<div id="top-nav" class="top-nav">
				<div class="container">

			
				<div class="top-menu"><ul id="menu-top" class="menu"><li id="menu-item-54121" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-54121"><a href="https://spokanefavs.com/">HOME</a></li>
<li id="menu-item-61443" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61443"><a href="https://spokanefavs.com/category/covid-19/">COVID-19</a></li>
<li id="menu-item-54026" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54026"><a href="https://spokanefavs.com/category/news/">News</a></li>
<li id="menu-item-54027" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-54027"><a href="https://spokanefavs.com/category/commentary/">Commentary</a>
<ul class="sub-menu">
	<li id="menu-item-54122" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54122"><a href="https://spokanefavs.com/ask/">ASK</a></li>
</ul>
</li>
<li id="menu-item-54044" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54044"><a href="http://spokanefavs.com/events/">Calendar</a></li>
<li id="menu-item-54032" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54032"><a href="https://spokanefavs.com/coffee-talk/">Coffee Talk</a></li>
<li id="menu-item-54029" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-54029"><a href="https://spokanefavs.com/about/">About</a>
<ul class="sub-menu">
	<li id="menu-item-54033" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54033"><a href="https://spokanefavs.com/about/formation-board/">Board of Trustees</a></li>
	<li id="menu-item-54047" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54047"><a href="https://spokanefavs.com/writers/contributors/">Writers</a></li>
	<li id="menu-item-54040" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54040"><a href="https://spokanefavs.com/about/staff/">Staff</a></li>
	<li id="menu-item-54035" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54035"><a href="https://spokanefavs.com/about/contact/">Contact</a></li>
	<li id="menu-item-54036" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54036"><a href="https://spokanefavs.com/about/editorial-independence-policy/">Editorial Independence Policy</a></li>
	<li id="menu-item-54037" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54037"><a href="https://spokanefavs.com/about/fundraising-and-donor-policy/">Fundraising and Donor Policy</a></li>
	<li id="menu-item-54038" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54038"><a href="https://spokanefavs.com/about/privacy-policy/">Privacy Policy</a></li>
	<li id="menu-item-54034" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54034"><a href="https://spokanefavs.com/about/comment-policy/">Comment Policy</a></li>
	<li id="menu-item-54041" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54041"><a href="https://spokanefavs.com/about/user-agreement/">User Agreement</a></li>
	<li id="menu-item-54039" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54039"><a href="https://spokanefavs.com/about/sitemap/">Sitemap</a></li>
</ul>
</li>
<li id="menu-item-54030" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-54030"><a href="https://spokanefavs.com/support-us/">Support Us</a>
<ul class="sub-menu">
	<li id="menu-item-54042" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54042"><a href="https://spokanefavs.com/advertise/">Advertise</a></li>
	<li id="menu-item-54043" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54043"><a href="https://spokanefavs.com/our-donors/">Our donors</a></li>
</ul>
</li>
<li id="menu-item-58602" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58602"><a href="http://favscenter.com">FāVS Center</a></li>
<li id="menu-item-60347" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60347"><a href="http://favsmembers.com">FāVS Members</a></li>
<li id="menu-item-61699" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61699"><a href="https://spokanefavs.com/favs-forward-podcast/">FāVS Forward Podcast</a></li>
</ul></div>
						<div class="search-block">
						<form method="get" id="searchform-header" action="https://spokanefavs.com/">
							<button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button>
							<input class="search-live" type="text" id="s-header" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  />
						</form>
					</div><!-- .search-block /-->
			<div class="social-icons">
		<a class="ttip-none" title="Rss" href="https://spokanefavs.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="https://www.facebook.com/SpokaneFAVS/" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="https://twitter.com/spokanefavs" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/spokanefavs/" target="_blank"><i class="fa fa-instagram"></i></a>
			</div>

	
	
				</div><!-- .container /-->
			</div><!-- .top-menu /-->
			
		<div class="header-content">

					<a id="slide-out-open" class="slide-out-open" href="#"><span></span></a>
		
			<div class="logo" style=" margin-top:15px; margin-bottom:15px;">
			<h2>								<a title="SpokaneFāVS" href="https://spokanefavs.com/">
					<img src="https://spokanefavs.com/wp-content/uploads/2019/06/Spokane-FAVS_logo-copy.png" alt="SpokaneFāVS"  /><strong>SpokaneFāVS </strong>
				</a>
			</h2>			</div><!-- .logo /-->
			<div class="e3lan e3lan-top">
			<a href="https://www.surveymonkey.com/r/qdc6zlg" title="" >
				<img src="https://spokanefavs.com/wp-content/uploads/2021/04/favssurvey.jpg" alt="" />
			</a>
				</div>			<div class="clear"></div>

		</div>
													<nav id="main-nav" class="fixed-enabled">
				<div class="container">

				
					<div class="main-menu"><ul id="menu-top-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-54121"><a href="https://spokanefavs.com/">HOME</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61443"><a href="https://spokanefavs.com/category/covid-19/">COVID-19</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54026"><a href="https://spokanefavs.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-54027"><a href="https://spokanefavs.com/category/commentary/">Commentary</a>
<ul class="sub-menu menu-sub-content">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54122"><a href="https://spokanefavs.com/ask/">ASK</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54044"><a href="http://spokanefavs.com/events/">Calendar</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54032"><a href="https://spokanefavs.com/coffee-talk/">Coffee Talk</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-54029"><a href="https://spokanefavs.com/about/">About</a>
<ul class="sub-menu menu-sub-content">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54033"><a href="https://spokanefavs.com/about/formation-board/">Board of Trustees</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54047"><a href="https://spokanefavs.com/writers/contributors/">Writers</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54040"><a href="https://spokanefavs.com/about/staff/">Staff</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54035"><a href="https://spokanefavs.com/about/contact/">Contact</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54036"><a href="https://spokanefavs.com/about/editorial-independence-policy/">Editorial Independence Policy</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54037"><a href="https://spokanefavs.com/about/fundraising-and-donor-policy/">Fundraising and Donor Policy</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54038"><a href="https://spokanefavs.com/about/privacy-policy/">Privacy Policy</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54034"><a href="https://spokanefavs.com/about/comment-policy/">Comment Policy</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54041"><a href="https://spokanefavs.com/about/user-agreement/">User Agreement</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54039"><a href="https://spokanefavs.com/about/sitemap/">Sitemap</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-54030"><a href="https://spokanefavs.com/support-us/">Support Us</a>
<ul class="sub-menu menu-sub-content">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54042"><a href="https://spokanefavs.com/advertise/">Advertise</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54043"><a href="https://spokanefavs.com/our-donors/">Our donors</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58602"><a href="http://favscenter.com">FāVS Center</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60347"><a href="http://favsmembers.com">FāVS Members</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61699"><a href="https://spokanefavs.com/favs-forward-podcast/">FāVS Forward Podcast</a></li>
</ul></div>										<a href="https://spokanefavs.com/?tierand=1" class="random-article ttip" title="Random Article"><i class="fa fa-random"></i></a>
					
					
				</div>
			</nav><!-- .main-nav /-->
					</header><!-- #header /-->

	
	
	<div id="main-content" class="container">

	
	
	
	
	
	<div class="content">

		
		<nav id="crumbs"><a href="https://spokanefavs.com/"><span class="fa fa-home" aria-hidden="true"></span> Home</a><span class="delimiter">/</span><a href="https://spokanefavs.com/category/commentary/">Commentary</a><span class="delimiter">/</span><span class="current">Everyday Is Mother&#8217;s Day: A Jewish Perspective</span></nav><script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"BreadcrumbList","@id":"#Breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"name":"Home","@id":"https:\/\/spokanefavs.com\/"}},{"@type":"ListItem","position":2,"item":{"name":"Commentary","@id":"https:\/\/spokanefavs.com\/category\/commentary\/"}}]}</script>
		

		
		<article class="post-listing post-64968 post type-post status-publish format-standard has-post-thumbnail  category-commentary tag-fathers-day-judaism tag-honor-they-father-and-mother tag-honor-thy-parents tag-judaism-2 tag-mothers-day tag-mothers-day-judaism" id="the-post">
			
			<div class="single-post-thumb">
			<img width="650" height="330" src="https://spokanefavs.com/wp-content/uploads/2021/05/mothersday_dp-650x330.jpg" class="attachment-slider size-slider wp-post-image" alt="" loading="lazy" />		</div>
	
		<div class="single-post-caption">mother and son at sunset/DepositPhoto</div> 


			<div class="post-inner">

							<h1 class="name post-title entry-title"><span itemprop="name">Everyday Is Mother&#8217;s Day: A Jewish Perspective</span></h1>

						
<p class="post-meta">
		
	<span class="post-meta-author"><i class="fa fa-user"></i><a href="https://spokanefavs.com/author/hyphenhuffmanparent/" title="">Hyphen Parent </a></span>
	
		
	<span class="tie-date"><i class="fa fa-clock-o"></i>3 hours ago</span>	
	<span class="post-cats"><i class="fa fa-folder"></i><a href="https://spokanefavs.com/category/commentary/" rel="category tag">Commentary</a></span>
	
	<span class="post-comments"><i class="fa fa-comments"></i><a href="https://spokanefavs.com/everyday-is-mothers-day-a-jewish-perspective/#disqus_thread"><span class="dsq-postid" data-dsqidentifier="64968 https://spokanefavs.com/?p=64968">Leave a comment</span></a></span>
<span class="post-views"><i class="fa fa-eye"></i>79 Views</span> </p>
<div class="clear"></div>
			
				<div class="entry">
					
					
					<div class='heateorSssClear'></div><div  class='heateor_sss_sharing_container heateor_sss_horizontal_sharing' heateor-sss-data-href='https://spokanefavs.com/everyday-is-mothers-day-a-jewish-perspective/'><div class='heateor_sss_sharing_title' style="font-weight:bold" >Share this story!</div><ul class="heateor_sss_sharing_ul"><li class="heateorSssSharingRound"><ss class="heateor_sss_square_count heateor_sss_facebook_count" style="visibility:visible;">6</ss><i style="width:26px;height:26px;border-radius:999px;" alt="Facebook" Title="Facebook" class="heateorSssSharing heateorSssFacebookBackground" onclick='heateorSssPopup("https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fspokanefavs.com%2Feveryday-is-mothers-day-a-jewish-perspective%2F")'><ss style="display:block;border-radius:999px;" class="heateorSssSharingSvg heateorSssFacebookSvg"></ss></i></li><li class="heateorSssSharingRound"><ss class="heateor_sss_square_count heateor_sss_twitter_count">&nbsp;</ss><i style="width:26px;height:26px;border-radius:999px;" alt="Twitter" Title="Twitter" class="heateorSssSharing heateorSssTwitterBackground" onclick='heateorSssPopup("http://twitter.com/intent/tweet?via=spokanefavs&text=Everyday%20Is%20Mother%27s%20Day%3A%20A%20Jewish%20Perspective&url=https%3A%2F%2Fspokanefavs.com%2Feveryday-is-mothers-day-a-jewish-perspective%2F")'><ss style="display:block;border-radius:999px;" class="heateorSssSharingSvg heateorSssTwitterSvg"></ss></i></li><li class="heateorSssSharingRound"><ss class="heateor_sss_square_count heateor_sss_reddit_count">&nbsp;</ss><i style="width:26px;height:26px;border-radius:999px;" alt="Reddit" Title="Reddit" class="heateorSssSharing heateorSssRedditBackground" onclick='heateorSssPopup("http://reddit.com/submit?url=https%3A%2F%2Fspokanefavs.com%2Feveryday-is-mothers-day-a-jewish-perspective%2F&title=Everyday%20Is%20Mother%27s%20Day%3A%20A%20Jewish%20Perspective")'><ss style="display:block;border-radius:999px;" class="heateorSssSharingSvg heateorSssRedditSvg"></ss></i></li><li class="heateorSssSharingRound"><ss class="heateor_sss_square_count heateor_sss_linkedin_count">&nbsp;</ss><i style="width:26px;height:26px;border-radius:999px;" alt="Linkedin" Title="Linkedin" class="heateorSssSharing heateorSssLinkedinBackground" onclick='heateorSssPopup("http://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fspokanefavs.com%2Feveryday-is-mothers-day-a-jewish-perspective%2F&title=Everyday%20Is%20Mother%27s%20Day%3A%20A%20Jewish%20Perspective")'><ss style="display:block;border-radius:999px;" class="heateorSssSharingSvg heateorSssLinkedinSvg"></ss></i></li><li class="heateorSssSharingRound"><ss class="heateor_sss_square_count heateor_sss_email_count">&nbsp;</ss><i style="width:26px;height:26px;border-radius:999px;" alt="Email" Title="Email" class="heateorSssSharing heateorSssEmailBackground"  onclick="window.open('mailto:?subject=' + decodeURIComponent('Everyday%20Is%20Mother%27s%20Day%3A%20A%20Jewish%20Perspective' ).replace('&', '%26') + '&body=' + decodeURIComponent('https%3A%2F%2Fspokanefavs.com%2Feveryday-is-mothers-day-a-jewish-perspective%2F' ), '_blank')"><ss style="display:block" class="heateorSssSharingSvg heateorSssEmailSvg"></ss></i></li><li class="heateorSssSharingRound"><ss class="heateor_sss_square_count heateor_sss_Facebook_Messenger_count">&nbsp;</ss><i style="width:26px;height:26px;border-radius:999px;" alt="Facebook Messenger" Title="Facebook Messenger" class="heateorSssSharing heateorSssFacebookMessengerBackground" onclick='heateorSssPopup("https://www.facebook.com/dialog/send?app_id=1423372461300205&display=popup&link=https%3A%2F%2Fspokanefavs.com%2Feveryday-is-mothers-day-a-jewish-perspective%2F&redirect_uri=https%3A%2F%2Fspokanefavs.com%2Feveryday-is-mothers-day-a-jewish-perspective%2F")'><ss style="display:block;border-radius:999px;" class="heateorSssSharingSvg heateorSssFacebookMessengerSvg"></ss></i></li><li class="heateorSssSharingRound"><ss class="heateor_sss_square_count heateor_sss_Pocket_count">&nbsp;</ss><i style="width:26px;height:26px;border-radius:999px;" alt="Pocket" Title="Pocket" class="heateorSssSharing heateorSssPocketBackground" onclick='heateorSssPopup("https://readitlaterlist.com/save?url=https%3A%2F%2Fspokanefavs.com%2Feveryday-is-mothers-day-a-jewish-perspective%2F&title=Everyday%20Is%20Mother%27s%20Day%3A%20A%20Jewish%20Perspective")'><ss style="display:block;border-radius:999px;" class="heateorSssSharingSvg heateorSssPocketSvg"></ss></i></li><li class="heateorSssSharingRound"><ss class="heateor_sss_square_count heateor_sss_instagram_count">&nbsp;</ss><i style="width:26px;height:26px;border-radius:999px;" alt="Instagram" Title="Instagram" class="heateorSssSharing heateorSssInstagramBackground"><a href="https://www.instagram.com/" rel="nofollow noopener" target="_blank"><ss style="display:block;border-radius:999px;" class="heateorSssSharingSvg heateorSssInstagramSvg"></ss></a></i></li><li class="heateorSssSharingRound"><ss class="heateor_sss_square_count heateor_sss_print_count">&nbsp;</ss><i style="width:26px;height:26px;border-radius:999px;" alt="Print" Title="Print" class="heateorSssSharing heateorSssPrintBackground" onclick='window.print()'><ss style="display:block" class="heateorSssSharingSvg heateorSssPrintSvg"></ss></i></li><li class="heateorSssSharingRound"><ss class="heateor_sss_square_count">&nbsp;</ss><i style="width:26px;height:26px;border-radius:999px;" title="More" alt="More" class="heateorSssSharing heateorSssMoreBackground" onclick="heateorSssMoreSharingPopup(this, 'https://spokanefavs.com/everyday-is-mothers-day-a-jewish-perspective/', 'Everyday%20Is%20Mother%27s%20Day%3A%20A%20Jewish%20Perspective', '' )" ><ss style="display:block" class="heateorSssSharingSvg heateorSssMoreSvg"></ss></i></li><li class="heateorSssSharingRound"><ss class="heateor_sss_square_count">&nbsp;</ss><i style="width:26px;height:26px;border-radius:999px;margin-left:9px !important;visibility:visible;" title="Total Shares" class="heateorSssSharing heateorSssTCBackground"><div class="heateorSssTotalShareCount" style="font-size: 16.12px">6</div><div class="heateorSssTotalShareText" style="font-size: 9.88px">Shares</div></i></li></ul><div class="heateorSssClear"></div></div><div class='heateorSssClear'></div>
<h2 id="h-everyday-is-mother-s-day-a-jewish-perspective">Everyday Is Mother&#8217;s Day: A Jewish Perspective</h2>



<p><strong>By <a href="https://spokanefavs.com/author/hyphenhuffmanparent/">Hyphen Parent</a></strong></p>



<p>I once read the declaration that every day is Mother’s Day and Father’s Day in Judaism because of the command to honor one’s parents. This, however, is an oversimplification. What about abusive parents? The short version of a very long discussion is that the command to honor parents is not a command to remain the victims of abuse. In Judaism, these verses are not considered “Get out of jail free” cards for the abusive parent. Yes one should honor their parents, but what that honor looks like can vary.  A rabbi once explained, “We’re commanded to honor our parents and sometimes, in difficult situations, the best way to honor them is to keep your distance.” </p>



<p>There is an oft-quoted Jewish story about honoring parents that says even if a parent berates an adult son in public, spits in his face, and tears the son’s clothes, the son should stay silent and not contradict his parents. However, discussions on this tale often leave out a major part of the story — the parents who behaved this way are suffering from dementia where they are not in control. Most sages rule this recommended child behavior does not apply to parents who are in control of their behavior and are able to act appropriately.</p>



<p><a href="https://www.halachafortoday.com/kibud-av-eim">Halachos For Today</a> explains further:</p>



<blockquote class="wp-block-quote"><p>If a parent is a wicked person and/or abusive to a child, most Poskim indeed rule that the child need not passively suffer and take the abuse, and may defend themselves and rebuke the parent for their inexcusable actions or do anything else that needs to be done to save themselves from an abusive situation. Nobody should suffer in silence. Nobody….</p></blockquote>



<p>There are limits to what is involved in honoring a parent. Here are just a few examples: According to halacha (Jewish law)&nbsp; it is forbidden for parents to be too demanding of children in the name of honor. A parent may not make a demand of a child that causes the child to lose income. A parent is not allowed to slander a child and if a parent does so, the child is allowed to respectfully state the accusation is false.&nbsp; If a parent commands an adult child not to speak to someone and the child wants to, there is no obligation to obey the parent. If parents try to interfere in their married child’s life, the children are allowed to send the parents away.&nbsp; As part of honoring parents, a child is expected to feed his/her parents if they cannot feed themselves, but, in most cases, the child does not need to use their own&nbsp; money to do so.</p>



<p>In <a href="https://hakirah.org/Vol%2012%20Dratch.pdf">Hakira Journal, Honoring Abusive Parents</a>, Rabbi Mark Dratch writes:</p>



<blockquote class="wp-block-quote"><p>R. David Cohen suggests that there are limits to how much a person is allowed to spend in order to fulfill a positive commandment—no more than one-fifth of one’s monetary assets—he argues that emotional distress and psychological consequences are excessive personal costs that free one from an obligation. He maintains that Halakhah does not re-victimize abused children by forcing them to honor their abusers; that would be a price much too high to pay..</p></blockquote>



<p>Furthermore, the Talmud concludes that while a child must expend time and effort in order to honor a parent, the child does not have to spend any personal resources; the obligation is fulfilled <em>mishel av, </em>with parental assets. While many acts of honor make demands on a child’s time, emotions, and energies, the emotional and psychological burdens imposed on an abused child in order to honor an abusive parent far surpass any appropriate <em>mi-shel ben </em>filial (responsibility). In addition, children are not obligated to honor parents when the expressions of that honor support sinful acts. Acts of abuse are sinful and children are not required to submit to them (<em>Dratch later cites examples explaining that “abuse” by parents includes neglect, physical abuse, sexual abuse, and emotional abuse</em>)&#8230; In addition, there are authorities who consider parents who violate rabbinic law to be excluded from the category of those who deserve honor as well.</p>



<p>When asked to summarize the Torah, Rabbi Hillel said, “What is hateful to you, do not do unto others. The rest is commentary. Go and study.” In some ways, this is very different from the Christian “Golden Rule.” I know of a woman who expressed immense relief when presented with the Jewish version. Jesus is often quoted as saying a version of, “Love your neighbor as yourself.” A friend once explained the Jewish version to someone. That person wept with relief. She had an abusive person in her life and she always struggled to love them.  She felt like a failure for not being able to do so. On top of struggling with the abuse, she also struggled with the guilt of not being able to fulfill that ideal. However, she realized while she couldn’t love them, she could treat them the way she wanted to be treated. She didn’t want to be abused and she didn’t want to be drawn into the horrible arguments, so she gave herself permission to distance from the abuser.<br><br>It’s important to note that Hillel’s famous line ends with, “Go and study.” In Judaism, there’s a strong tradition of always studying and learning Torah. He provided a very brief summary and acknowledged there is so much more to the Torah. So while people should treat others the way they want to be treated, people should also continue to study — Torah and themselves. One studies Torah by reading from the source, reading commentaries, discussing, and consulting with people who have more training and education. So too should people study themselves and their experiences with the help of therapists, books, and research.</p>



<p>Rabbi Dov Linzer explains:</p>



<blockquote class="wp-block-quote"><p><br>&#8230;people should not be making such decisions on their own. When someone has been hurt, he or she is often not in the best position to determine what the best course of action is, even for their own emotional well-being.  It is not advisable for people in emotional distress to  decide on their own whether it is best for them to talk to their mother or cut off all communication.  It is not advisable for them to decide on their own whether that they should not say kaddish, sit shivah, or the like.  A person might impulsively decide not to sit shiva, only to years later regret this decision, winding up feeling that by not sitting shiva he has allowed his father to continue to have a hold over him and that this has prevented him from achieving closure.  At the end of the day, it is best that these decisions by made with help from a psychologist, rav, or with someone with the experience, wisdom and training to determine what decision ultimately is the right one, both for their parent, be he or she living or dead, and for their own mental and emotional health and well-being. </p><cite><a href="https://library.yctorah.org/2018/02/must-a-person-honor-and-mourn-for-an-abusive-parent/">Honoring an Abusive Parent?</a></cite></blockquote>



<figure class="wp-block-image size-large"><a href="https://spokanefavs.com/support-us/"><img loading="lazy" width="728" height="100" src="https://spokanefavs.com/wp-content/uploads/2021/01/Do-you-appreciate-SpokaneFāVS_-Become-a-Sustaining-Member-Today.png" alt="" class="wp-image-64087" srcset="https://spokanefavs.com/wp-content/uploads/2021/01/Do-you-appreciate-SpokaneFāVS_-Become-a-Sustaining-Member-Today.png 728w, https://spokanefavs.com/wp-content/uploads/2021/01/Do-you-appreciate-SpokaneFāVS_-Become-a-Sustaining-Member-Today-427x59.png 427w" sizes="(max-width: 728px) 100vw, 728px" /></a></figure>
<div id="wpautbox-60983096c25d3" class="wpautbox-below"><input type="hidden" class="wpautbox-input-authorid" value="1283" /><ul class="a-tab-nav"><li class="a-tab-active"><a href="#wpautbox_about"><i class="el-icon-user wpautbox-icon"></i> About the Author</a></li><li><a href="#wpautbox_latest-post"><i class="el-icon-list wpautbox-icon"></i> Latest Posts</a></li></ul><div class="a-tab-container"><div class="a-tab-content" id="wpautbox_about"><div class="wpautbox-avatar wpautbox-avatar-circle"><a href="https://spokanefavs.com/author/hyphenhuffmanparent/"><img alt='' src='http://spokanefavs.com/wp-content/uploads/2014/08/HyphenHuffmanparent-120x120.jpeg' srcset='https://spokanefavs.com/wp-content/uploads/2014/08/HyphenHuffmanparent-240x240.jpeg 2x' class='avatar avatar-120 photo' height='120' width='120' loading='lazy'/></a></div><div class="wpautbox-author-meta"><h4 class="wpautbox-name"><span>About</span> <a href="https://spokanefavs.com/author/hyphenhuffmanparent/">Hyphen Parent</a></h4><p>Dorothy-Ann Parent (better known as Hyphen) is a writer, a traditional Jew, a seeker of justice, a lover of stories, the self-proclaimed Jewish Molly Weasley, hobbit-sized, and best not left unattended in a bookshop or animal shelter.</p>
</div></div><div class="a-tab-content" id="wpautbox_latest-post"><ul class="wpautbox-post_type-list wpautbox-latest-post"><li><a href="https://spokanefavs.com/everyday-is-mothers-day-a-jewish-perspective/">Everyday Is Mother&#8217;s Day: A Jewish Perspective</a> <span class="wpautbox-date">- May 9, 2021</span></li><li><a href="https://spokanefavs.com/bat-mitzvah-planning-in-a-pandemic/">Bat Mitzvah Planning In A Pandemic</a> <span class="wpautbox-date">- April 22, 2021</span></li><li><a href="https://spokanefavs.com/ask-a-jew-breaking-a-glass-at-a-wedding/">Ask A Jew: Breaking A Glass at a Wedding</a> <span class="wpautbox-date">- April 7, 2021</span></li><li><a href="https://spokanefavs.com/ask-a-jew-kosher-for-passover/">Ask a Jew: Kosher for Passover</a> <span class="wpautbox-date">- March 21, 2021</span></li><li><a href="https://spokanefavs.com/ask-a-jew-are-jewish-dietary-laws-outdated/">Ask A Jew: Are Jewish Dietary Laws Outdated?</a> <span class="wpautbox-date">- March 11, 2021</span></li><li><a href="https://spokanefavs.com/ask-a-jew-online-gathering-places/">Ask A Jew: Online Gathering Places?</a> <span class="wpautbox-date">- February 7, 2021</span></li><li><a href="https://spokanefavs.com/dont-forgive-them-for-they-know-exactly-what-they-do/">Don&#8217;t forgive them for they know exactly what they do</a> <span class="wpautbox-date">- January 11, 2021</span></li><li><a href="https://spokanefavs.com/ask-a-jew-chanukah-greetings-for-non-jews/">Ask A Jew: Chanukah Greetings for Non-Jews</a> <span class="wpautbox-date">- January 4, 2021</span></li><li><a href="https://spokanefavs.com/ask-a-jew-misusing-sacred-jewish-words/">Ask A Jew: Misusing Sacred Jewish Words</a> <span class="wpautbox-date">- December 13, 2020</span></li><li><a href="https://spokanefavs.com/ask-a-jew-wearing-the-star-of-david/">Ask A Jew: Wearing the Star of David</a> <span class="wpautbox-date">- August 6, 2020</span></li></ul><a href="https://spokanefavs.com/author/hyphenhuffmanparent/" class="wpautbox-allpost">View All Posts</a></div></div></div>					
									</div><!-- .entry /-->


								<div class="clear"></div>
			</div><!-- .post-inner -->

			<script type="application/ld+json">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</script>
		</article><!-- .post-listing -->
		<p class="post-tag">Tags <a href="https://spokanefavs.com/tag/fathers-day-judaism/" rel="tag">father&#039;s day judaism</a> <a href="https://spokanefavs.com/tag/honor-they-father-and-mother/" rel="tag">honor they father and mother</a> <a href="https://spokanefavs.com/tag/honor-thy-parents/" rel="tag">honor thy parents</a> <a href="https://spokanefavs.com/tag/judaism-2/" rel="tag">judaism</a> <a href="https://spokanefavs.com/tag/mothers-day/" rel="tag">mother's day</a> <a href="https://spokanefavs.com/tag/mothers-day-judaism/" rel="tag">mother&#039;s day judaism</a></p>

		
		

				<div class="post-navigation">
			<div class="post-previous"><a href="https://spokanefavs.com/celebrate-curiosity-art-contest-open-to-local-artists/" rel="prev"><span>Previous</span> &#8220;Celebrate Curiosity&#8221; Art Contest Deadline Approaching May 12</a></div>
			<div class="post-next"></div>
		</div><!-- .post-navigation -->
		
			<section id="related_posts">
		<div class="block-head">
			<h3>Related Articles</h3><div class="stripe-line"></div>
		</div>
		<div class="post-listing">
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="https://spokanefavs.com/ask-an-eastern-orthodox-christian-will-god-forgive-the-blasphemy-of-the-holy-spirit/">
						<img width="310" height="165" src="https://spokanefavs.com/wp-content/uploads/2018/05/askorthodox-310x165.png" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" loading="lazy" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="https://spokanefavs.com/ask-an-eastern-orthodox-christian-will-god-forgive-the-blasphemy-of-the-holy-spirit/" rel="bookmark">Ask An Eastern Orthodox Christian: Will God Forgive the Blasphemy of the Holy Spirit?</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>2 days ago</span></p>
			</div>
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="https://spokanefavs.com/finding-meaning-in-the-pandemic/">
						<img width="310" height="165" src="https://spokanefavs.com/wp-content/uploads/2021/05/pandemic_DP-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" loading="lazy" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="https://spokanefavs.com/finding-meaning-in-the-pandemic/" rel="bookmark">Finding Meaning in the Pandemic</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>3 days ago</span></p>
			</div>
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="https://spokanefavs.com/covid-the-view-from-the-porch/">
						<img width="310" height="165" src="https://spokanefavs.com/wp-content/uploads/2020/08/smith_porch-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" loading="lazy" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="https://spokanefavs.com/covid-the-view-from-the-porch/" rel="bookmark">COVID: The View From the Porch</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>5 days ago</span></p>
			</div>
						<div class="clear"></div>
		</div>
	</section>
	
			
	<section id="check-also-box" class="post-listing check-also-right">
		<a href="#" id="check-also-close"><i class="fa fa-close"></i></a>

		<div class="block-head">
			<h3>Check Also</h3>
		</div>

				<div class="check-also-post">
						
			<div class="post-thumbnail">
				<a href="https://spokanefavs.com/can-peace-making-include-protests/">
					<img width="310" height="165" src="https://spokanefavs.com/wp-content/uploads/2021/05/protest_DP-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" loading="lazy" />					<span class="fa overlay-icon"></span>
				</a>
			</div><!-- post-thumbnail /-->
						
			<h2 class="post-title"><a href="https://spokanefavs.com/can-peace-making-include-protests/" rel="bookmark">Can Peace-Making Include Protests?</a></h2>
			<p>People of faith, particularly Christians, seem to be conflicted about whether protests do any good, or even if protests are “Christian.”</p>
		</div>
			</section>
			
			
	
		
				
<div id="comments">


<div class="clear"></div>
	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/everyday-is-mothers-day-a-jewish-perspective/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://spokanefavs.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='64968' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form>	</div><!-- #respond -->
	

</div><!-- #comments -->

	</div><!-- .content -->
<aside id="sidebar">
	<div class="theiaStickySidebar">
<div id="media_image-61" class="widget widget_media_image"><div class="widget-top"><h4> </h4><div class="stripe-line"></div></div>
						<div class="widget-container"><a href="https://smile.amazon.com/ref=smi_ext_ch_47-4309024_dl?_encoding=UTF8&#038;ein=47-4309024&#038;ref_=smi_chpf_redirect&#038;ref_=smi_ext_ch_47-4309024_cl"><img width="300" height="251" src="https://spokanefavs.com/wp-content/uploads/2020/09/amazonsmile.png" class="image wp-image-63063  attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" /></a></div></div><!-- .widget /--><div id="media_image-60" class="widget widget_media_image"><div class="widget-top"><h4>Our Sponsors</h4><div class="stripe-line"></div></div>
						<div class="widget-container"><a href="https://stgertrudes.org/"><img width="300" height="250" src="https://spokanefavs.com/wp-content/uploads/2021/01/SpokaneFavsWebAd.jpg" class="image wp-image-63977  attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" /></a></div></div><!-- .widget /--><div id="media_image-40" class="widget widget_media_image"><div class="widget-top"><h4> </h4><div class="stripe-line"></div></div>
						<div class="widget-container"><a href="http://www.holytrinityspokane.org/"><img width="300" height="250" src="https://spokanefavs.com/wp-content/uploads/2019/11/orthodoxad2.png" class="image wp-image-60481  attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" /></a></div></div><!-- .widget /--><div id="media_image-58" class="widget widget_media_image"><div class="widget-top"><h4> </h4><div class="stripe-line"></div></div>
						<div class="widget-container"><a href="https://www.humanities.org/"><img width="376" height="130" src="https://spokanefavs.com/wp-content/uploads/2020/11/Humanities-logo.jpg" class="image wp-image-63470  attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" /></a></div></div><!-- .widget /--><div id="custom_html-4" class="widget_text widget widget_custom_html"><div class="widget-top"><h4> </h4><div class="stripe-line"></div></div>
						<div class="widget-container"><div class="textwidget custom-html-widget"><div id="RecentComments" class="dsq-widget">
 <h2>Recent Comments</h2>
 <script type="text/javascript" src="https://spokanefavs.disqus.com/recent_comments_widget.js?num_items=5&hide_mods=0&hide_avatars=0&avatar_size=32&excerpt_length=100"></script>
</div></div></div></div><!-- .widget /-->	</div><!-- .theiaStickySidebar /-->
</aside><!-- #sidebar /-->	<div class="clear"></div>
</div><!-- .container /-->

<footer id="theme-footer">
	<div id="footer-widget-area" class="footer-3c">

	
	

	
		
	</div><!-- #footer-widget-area -->
	<div class="clear"></div>
</footer><!-- .Footer /-->
				
<div class="clear"></div>
<div class="footer-bottom">
	<div class="container">
		<div class="alignright">
			Powered by <a href="http://wordpress.org">WordPress</a> | Designed by <a href="http://tielabs.com/">TieLabs</a>		</div>
				<div class="social-icons">
		<a class="ttip-none" title="Rss" href="https://spokanefavs.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="https://www.facebook.com/SpokaneFAVS/" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="https://twitter.com/spokanefavs" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/spokanefavs/" target="_blank"><i class="fa fa-instagram"></i></a>
			</div>

		
		<div class="alignleft">
			© Copyright 2021, All Rights Reserved		</div>
		<div class="clear"></div>
	</div><!-- .Container -->
</div><!-- .Footer bottom -->

</div><!-- .inner-Wrapper -->
</div><!-- #Wrapper -->
</div><!-- .Wrapper-outer -->
	<div id="topcontrol" class="fa fa-angle-up" title="Scroll To Top"></div>
<div id="fb-root"></div>
		<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script><script type='text/javascript' id='stripe-handler-ng-js-extra'>
/* <![CDATA[ */
var wpASPNG = {"iframeUrl":"https:\/\/spokanefavs.com\/asp-payment-box\/","ppSlug":"asp-payment-box","prefetch":"","ckey":"2fb8b914dd0b99d08e64de8aec7c692d"};
/* ]]> */
</script>
<script type='text/javascript' src='https://spokanefavs.com/wp-content/plugins/stripe-payments/public/assets/js/stripe-handler-ng.js' id='stripe-handler-ng-js'></script>
<script type='text/javascript' src='https://spokanefavs.com/wp-content/plugins/wp-author-box-pro/lib/js/jquery.a-tab.js' id='jquery-wpautbox-tab-js'></script>
<script type='text/javascript' id='jquery-wpautbox-pro-js-extra'>
/* <![CDATA[ */
var wpautboxAjax = {"ajaxurl":"https:\/\/spokanefavs.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://spokanefavs.com/wp-content/plugins/wp-author-box-pro/lib/js/jquery.wpautbox.js' id='jquery-wpautbox-pro-js'></script>
<script type='text/javascript' id='tie-scripts-js-extra'>
/* <![CDATA[ */
var tie = {"mobile_menu_active":"true","mobile_menu_top":"","lightbox_all":"true","lightbox_gallery":"true","woocommerce_lightbox":"","lightbox_skin":"dark","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"1","is_singular":"1","reading_indicator":"","lang_no_results":"No Results","lang_results_found":"Results Found"};
/* ]]> */
</script>
<script type='text/javascript' src='https://spokanefavs.com/wp-content/themes/sahifa/js/tie-scripts.js' id='tie-scripts-js'></script>
<script type='text/javascript' src='https://spokanefavs.com/wp-content/themes/sahifa/js/ilightbox.packed.js' id='tie-ilightbox-js'></script>
<script type='text/javascript' id='heateor_sss_sharing_js-js-before'>
function heateorSssLoadEvent(e) {var t=window.onload;if (typeof window.onload!="function") {window.onload=e}else{window.onload=function() {t();e()}}};	var heateorSssSharingAjaxUrl = 'https://spokanefavs.com/wp-admin/admin-ajax.php', heateorSssCloseIconPath = 'https://spokanefavs.com/wp-content/plugins/sassy-social-share/public/../images/close.png', heateorSssPluginIconPath = 'https://spokanefavs.com/wp-content/plugins/sassy-social-share/public/../images/logo.png', heateorSssHorizontalSharingCountEnable = 1, heateorSssVerticalSharingCountEnable = 0, heateorSssSharingOffset = -10; var heateorSssMobileStickySharingEnabled = 0;var heateorSssCopyLinkMessage = "Link copied.";var heateorSssUrlCountFetched = [], heateorSssSharesText = 'Shares', heateorSssShareText = 'Share';function heateorSssPopup(e) {window.open(e,"popUpWindow","height=400,width=600,left=400,top=100,resizable,scrollbars,toolbar=0,personalbar=0,menubar=no,location=no,directories=no,status")};var heateorSssWhatsappShareAPI = "web";
</script>
<script type='text/javascript' src='https://spokanefavs.com/wp-content/plugins/sassy-social-share/public/js/sassy-social-share-public.js' id='heateor_sss_sharing_js-js'></script>
<script type='text/javascript' src='https://spokanefavs.com/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' src='https://spokanefavs.com/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script type='text/javascript' src='https://spokanefavs.com/wp-content/themes/sahifa/js/search.js' id='tie-search-js'></script>
</body>
</html>